aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc40
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2000-12-06 05:36:59 +0800
committerobrien <obrien@FreeBSD.org>2000-12-06 05:36:59 +0800
commitdf44be85ca2140daf8858072e4d93ef78a9b6db1 (patch)
treee3a1e8921c8786589c0e4d8f9935aacd9460516f /lang/gcc40
parent62e6e92a67abc0d2e28e321b394ef8edb0e82ecc (diff)
downloadfreebsd-ports-gnome-df44be85ca2140daf8858072e4d93ef78a9b6db1.tar.gz
freebsd-ports-gnome-df44be85ca2140daf8858072e4d93ef78a9b6db1.tar.zst
freebsd-ports-gnome-df44be85ca2140daf8858072e4d93ef78a9b6db1.zip
Change name of programs from e<program_name> to g<program_name>, since
e<program_name> conflicts with the egcs port. I'm open to a better nameing scheme. Also change the shared libs configuring logic a little bit due to changed way of doing it on libstdc++-v3, which this snapshot uses by default.
Diffstat (limited to 'lang/gcc40')
-rw-r--r--lang/gcc40/Makefile27
-rw-r--r--lang/gcc40/pkg-plist8
2 files changed, 17 insertions, 18 deletions
diff --git a/lang/gcc40/Makefile b/lang/gcc40/Makefile
index 41832fb0d06b..fa6b2fc6a0ae 100644
--- a/lang/gcc40/Makefile
+++ b/lang/gcc40/Makefile
@@ -34,7 +34,6 @@ NO_CDROM= 'dated material'
##INSTALL_WRKSRC= ${WRKDIR}/build
##CONFIGURE_SCRIPT= ${WRKSRC}/configure
EGCS_REV= 2.97
-LIBSTDCPP_REV= 4
SRCDIR= ${WRKDIR}/gcc-${SNAPVER}
WRKSRC= ${WRKDIR}/build
PATCH_ARGS= -d ${SRCDIR} -E ${PATCH_STRIP}
@@ -52,7 +51,7 @@ CONFIGURE_TARGET= ${ARCH}-portbld-freebsdaout${OSREL}
.endif
PLIST_SUB= EGCS_REV=${EGCS_REV} GNU_HOST=${CONFIGURE_TARGET} \
- LIBSTDCPP_REV=${LIBSTDCPP_REV} SNAPVER=${SNAPVER}
+ SNAPVER=${SNAPVER}
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BISON= yes
@@ -60,6 +59,8 @@ CONFIGURE_ARGS= --disable-nls --with-gnu-as --with-gnu-ld \
--with-gxx-include-dir=${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}/include/g++
.if defined(WANT_SHAREDLIBS)
CONFIGURE_ARGS+= --enable-shared
+.else
+CONFIGURE_ARGS+= --disable-shared
.endif
.if defined(WANT_THREADS_SUPPORT)
CONFIGURE_ARGS+= --enable-threads
@@ -67,7 +68,7 @@ CONFIGURE_ARGS+= --enable-threads
CONFIGURE_ARGS+= --enable-threads=posix
.endif
ALL_TARGET= bootstrap
-MAN1= ecpp.1 eg++.1 eg77.1 egcc.1
+MAN1= gcpp.1 gg++.1 gg77.1 ggcc.1
pre-configure:
@(MAJ=`sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
@@ -102,10 +103,10 @@ post-install:
do \
strip $$prog ; \
done )
- ${MV} ${PREFIX}/bin/gcc ${PREFIX}/bin/egcc
- ${MV} ${PREFIX}/bin/g++ ${PREFIX}/bin/eg++
- ${MV} ${PREFIX}/bin/g77 ${PREFIX}/bin/eg77
- ${MV} ${PREFIX}/bin/g++filt ${PREFIX}/bin/eg++filt
+ ${MV} ${PREFIX}/bin/gcc ${PREFIX}/bin/ggcc
+ ${MV} ${PREFIX}/bin/g++ ${PREFIX}/bin/gg++
+ ${MV} ${PREFIX}/bin/g77 ${PREFIX}/bin/gg77
+ ${MV} ${PREFIX}/bin/g++filt ${PREFIX}/bin/gg++filt
${MV} ${PREFIX}/bin/gccbug ${PREFIX}/bin/gccbug-${SNAPVER}
${RM} -f ${PREFIX}/bin/${GNU_HOST}-c++
${RM} -f ${PREFIX}/bin/cpp
@@ -113,16 +114,14 @@ post-install:
# with the stock compiler.
${MV} ${PREFIX}/lib/libiberty.a \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}
- ${MV} -f ${PREFIX}/lib/libstdc++.a.${LIBSTDCPP_REV} \
+ ${MV} -f ${PREFIX}/lib/libstdc++.a \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}
- cd ${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV} ; \
- ${LN} -sf libstdc++.a.${LIBSTDCPP_REV} libstdc++.a
${MV} -f ${PREFIX}/lib/libzgcj.* \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}
- ${MV} ${PREFIX}/man/man1/gcc.1 ${PREFIX}/man/man1/egcc.1
- ${MV} ${PREFIX}/man/man1/g++.1 ${PREFIX}/man/man1/eg++.1
- ${MV} ${PREFIX}/man/man1/g77.1 ${PREFIX}/man/man1/eg77.1
- ${MV} ${PREFIX}/man/man1/cpp.1 ${PREFIX}/man/man1/ecpp.1
+ ${MV} ${PREFIX}/man/man1/gcc.1 ${PREFIX}/man/man1/ggcc.1
+ ${MV} ${PREFIX}/man/man1/g++.1 ${PREFIX}/man/man1/gg++.1
+ ${MV} ${PREFIX}/man/man1/g77.1 ${PREFIX}/man/man1/gg77.1
+ ${MV} ${PREFIX}/man/man1/cpp.1 ${PREFIX}/man/man1/gcpp.1
.if defined(WANT_SHAREDLIBS)
${MV} -f ${PREFIX}/lib/libstdc++.so* \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}
diff --git a/lang/gcc40/pkg-plist b/lang/gcc40/pkg-plist
index 937fbde90edf..264f8e69036e 100644
--- a/lang/gcc40/pkg-plist
+++ b/lang/gcc40/pkg-plist
@@ -1,8 +1,8 @@
@comment $FreeBSD$
-bin/eg++filt
-bin/eg++
-bin/eg77
-bin/egcc
+bin/gg++filt
+bin/gg++
+bin/gg77
+bin/ggcc
bin/%%GNU_HOST%%-gcc
bin/%%GNU_HOST%%-g++
bin/gccbug-%%SNAPVER%%
21ac679'>- update to 5.0.21rm2012-01-063-4/+5 * - update to 1.37rm2012-01-063-4/+4 * - Add missing BUILD_DEPENDS to allow the module to work, silence buildswills2012-01-061-2/+4 * - Add missing BUILD_DEPENDS to allow the module to work, silence buildswills2012-01-061-2/+4 * - Reassignment of ECHO_MSG breaks 'make readme', so remove and reformat IGNORE.jgh2012-01-051-8/+6 * End WWW CPAN URL with a "/"ehaupt2011-12-283-3/+3 * Mark as broken on powerpc: fails to install.linimon2011-12-281-0/+4 * - update to 4.0.0scheidell2011-12-232-4/+5 * Fix compilation with clang. This does not fix the port, since there is ase2011-12-211-0/+11 * update math/R to 2.14.0, math/R-cran-sp to 0.9-91, and adjustbf2011-11-272-2/+2 * - Move PKGNAMEPREFIX defined in each R-cran- related ports Makefiletota2011-11-162-2/+0 * - Unbreak - fix build with latest x11-toolkits/fltkgahr2011-11-1510-4/+343 * - Update to 1.0.5miwi2011-11-142-4/+3 * - Update to 4.6.1miwi2011-11-133-5/+170 * - Mark BROKEN: does not compile with new fltkpav2011-11-051-0/+2 * - Update to 3.22clsung2011-10-273-3/+6 * The vast majority of pkg-descr files had the following format when theydougb2011-10-241-2/+0 * Remove more tags from pkg-descr files fo the form:dougb2011-10-241-3/+0 * - Update dependencies after KDE ports upgrade.avilla2011-10-174-5/+2 * update math/R to 2.13.2, and adjust dependent portsbf2011-10-112-0/+2 * - Fix LICENSE (Artistic 1 instead of Artistic 2)culot2011-10-071-1/+1 * - Update RUN_DEPENDS [1]sbz2011-10-051-1/+4 * - Chase devel/gwenhywfar has a shlib version bumpswills2011-10-031-0/+1 * - Chase devel/gwenhywfar has a shlib version bumpswills2011-10-031-1/+1 * - Update to 5.0.16swills2011-10-033-5/+6 * - Update to 1.35dhn2011-09-253-4/+3 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-2410-17/+13 * - Add a new port: finance/R-cran-gmmtota2011-09-234-0/+36 * - Add a new port: finance/R-cran-RFinanceYJtota2011-09-164-0/+31 * - Update to 0.02az2011-09-094-10/+14 * - Replace ../../authors in MASTER_SITE_SUBDIR with CPAN:CPANID macro.az2011-09-083-4/+4 * - Update To 6.0.3beech2011-09-078-58/+190 * Update to 0.9.1.rakuco2011-09-073-103/+66 * - Update to 3.7.1swills2011-09-052-8/+4 * - Update to 4.6.0beech2011-08-313-21/+45 * - Update to 1.19sunpoet2011-08-303-5/+3 * - Pet portlintsunpoet2011-08-301-6/+9 * - Update to 1.17sunpoet2011-08-282-4/+10 * - Update to 1.34miwi2011-08-263-7/+7 * Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where ...kwm2011-08-241-1/+1 * - Pass maintainership to new voluteer <via email>wen2011-08-222-2/+2 * Add option for experimental localized tax categories [1]kwm2011-08-201-5/+10 * - Update to 2.6.3beech2011-08-184-8/+10 * Update master_sitebapt2011-08-021-1/+1 * Update to 4.3.1arved2011-08-023-7/+10 * Chase devel/gwenhywfar shlib bump.kwm2011-08-012-1/+2 * Update to 5.0.14.kwm2011-08-014-10/+22 * - Chase guile shared lib bumpjlaffaye2011-07-311-0/+1 * Convert custom *_DEPENDS lines of devel/py-gobject to USE_GNOME=pygobject orkwm2011-07-301-3/+2 * - Mark broken with Ruby 1.9swills2011-07-271-1/+5 * - Chase gpgme shared lib bump.jlaffaye2011-07-211-1/+1 * Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,linimon2011-07-211-1/+1 * Update to 2.4.1.kwm2011-07-173-34/+477 * Update to 2.4.7.kwm2011-07-172-5/+5 * - Update to 3.7.0pgollucci2011-06-262-3/+3 * - Cannoicalize the WWW: [again],pgollucci2011-06-241-1/+1 * - Replace ../../authors in MASTER_SITE_SUBDIR with CPAN:CPANID macro.az2011-06-211-1/+2 * - Fix dependency versionspgollucci2011-06-211-1/+1 * - update to 1.30bapt2011-06-182-3/+3 * Update to 1.33jlaffaye2011-06-113-4/+4 * Maintainers addresses are not valid anymore put the port back to the poolbapt2011-06-101-1/+1 * - Update to 0.94wen2011-06-025-37/+41 * - Update to 5.0.7wen2011-06-022-7/+5 * - Update to 1.1jadawin2011-05-303-5/+55 * Upgrade to 0.8.6 (bug fixes).thierry2011-05-232-5/+5 * A library assists in handling money and different currencies.swills2011-05-034-0/+30 * One more bunch of unmaintained expired ports removalbapt2011-05-0214-154/+0 * Bump PORTREVISION after open-mofit updatemakc2011-05-021-1/+1 * Fix build with open-motif-2.3.3makc2011-05-022-1/+13 * The former maintainer only adopted these ports to save themdougb2011-04-272-0/+6 * By Maintainer's request, toss these ports back into the pooldougb2011-04-272-2/+2 * Connect skroogemakc2011-04-171-0/+1 * Add new port finance/skrooge:makc2011-04-174-0/+592 * Update to 2.4.5kwm2011-04-113-4/+7 * - Update to 3101jadawin2011-04-063-6/+8 * - update to 0.19bapt2011-04-042-3/+3 * - Update to 8.05culot2011-04-032-3/+3 * Bitcoin is a peer-to-peer network based digital currency.skreuzer2011-04-035-0/+50 * - Update to 4.03.5wen2011-04-013-175/+579 * - update to 0.17bapt2011-03-252-5/+7 * - update to 1.08bapt2011-03-252-3/+6 * Upgrade to 0.8.4 (bugs fixes).thierry2011-03-252-3/+3 * - Update my email to FreeBSDpawel2011-03-241-1/+1 * - Get Rid MD5 supportmiwi2011-03-1971-71/+0 * - Update to 5.0.5wen2011-03-174-4/+16 * - Pass maintainership to submitterwen2011-03-172-2/+2 * Remove deprecation, points to the SF websitebapt2011-03-164-11/+2 * Deprecate unmaintained ports from finance where upstream disapear and/orbapt2011-03-162-0/+6 * Upgrade to 0.8.3: fixes several bugs.thierry2011-03-102-3/+3 * Libalkimia is a library with common classes and functionality used by financeavilla2011-03-095-0/+57 * - dbi.0 => dbi.1clsung2011-03-071-2/+2 * - Update to 4.4miwi2011-03-043-9/+10 * Fix hopefully the last typo. Spell PORTSDIR correctly in the webkit section.kwm2011-03-031-1/+1 * Clear up some unused depends. bump portrevision for this change.kwm2011-03-021-5/+4 * Only check for libgwengui-qt4.so when the KBANKING option is selected.kwm2011-03-021-2/+2 * Remove a space before .else in the PYTHON section.kwm2011-03-011-1/+1 * Update to 2.4.3.kwm2011-03-016-281/+298 * Update to 4.5.3.kwm2011-03-015-84/+42 * Update to 5.0.4kwm2011-03-018-495/+330 * Chase after net/openldap24-server update.delphij2011-02-251-0/+1 * - Move over to py25+ or abovemiwi2011-02-255-7/+8 * Upgrade to 0.8.2 (bugfix).thierry2011-02-242-3/+3 * Update to 0.8.1.thierry2011-02-225-40/+18 * - Update to 8.03miwi2011-02-193-3/+5 * - upgrade to 1.28bapt2011-02-192-5/+6 * - Update to 0.9.2dhn2011-02-188-480/+30 * - Bump PORTREVISION to chase the update of devel/py-pyrowen2011-02-142-3/+2 * - Update to 1.31culot2011-02-123-4/+4 * - Update to 8.01 for TY 2010beat2011-01-264-49/+46 * - Update to 2.5.1decke2011-01-053-5/+5 * - finance/kmymoney-kde4: Update to 4.5.2fluffy2010-12-303-4/+76 * - DISTNAME= ${PORTNAME}-${PORTVERSION} is the default and not needed.pgollucci2010-12-301-1/+0 * - Add PORTSCOUT limitwen2010-12-292-1/+2 * - Chase security/libksba shlib version bumpglarkin2010-12-161-0/+1 * Sync to new bsd.autotools.mkade2010-12-0410-10/+10 * Reset hideo@lastamericanempire.com due to maintainer-timeouts and nolinimon2010-12-023-3/+3 * Conceived in PHP and MySQL, PrestaShop is a really modular and customizablewen2010-11-235-0/+75 * Update to 4.5.1makc2010-11-183-111/+35 * Update to 1.29makc2010-11-183-6/+4 * - Update to 1.4.7wen2010-11-162-4/+3 * - Update to 5.0.15wen2010-11-094-8/+6 * - Add upstream patches, including:sunpoet2010-11-0710-28/+487 * - Update to 2.04wen2010-11-012-4/+4 * - Bump PORTEPOCH here which missed in last commitwen2010-10-252-0/+2 * - Back to 5.0.14 because upstream recall 5.0.15wen2010-10-254-8/+8 * - Update to 5.0.15wen2010-10-184-8/+8 * Punt autoconf267->autoconf268ade2010-10-162-2/+2 * Round one migration of ports from automake{19,110} to automake111ade2010-10-062-2/+2 * - update to 1.16leeym2010-10-052-7/+7 * Fix the quote price editor adds price data as wrong date. Bump themezz2010-10-042-1/+12 * Makes gnucash-docs as a dependency optional.mezz2010-10-031-5/+9 * Update to 1.15az2010-09-262-4/+4 * - Update finance/kmymoney-kde4 to 4.5 releasefluffy2010-09-257-49/+162 * - only 13% of the p5- ports embed @comment $FreeBSD$:pgollucci2010-09-241-1/+0 * - Update to 2.5.0decke2010-09-212-5/+5 * - Update to 3.11.4wen2010-09-173-7/+6 * - Update to 1.4.6wen2010-09-162-4/+4 * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-162-4/+4 * - Update to 5.0.14wen2010-09-104-10/+10 * Fix build with upcoming KDE 4.5makc2010-08-311-0/+7 * - Update to 5.0.11lwhsu2010-08-266-1214/+1234 * Fix build with upcoming KDE 4.5makc2010-08-221-0/+1 * Revert CATEGORIES order despite portlint warning.makc2010-08-191-1/+2 * Update to 1.28makc2010-08-184-23/+12 * Chase the aqbanking shared lib version.marcus2010-08-151-1/+1 * - Update to 1.27amdmi32010-08-064-14/+39 * - Update to 2.4.1decke2010-08-053-9/+10 * Reassign some of ahze's ports to gnome@.linimon2010-07-262-2/+2 * Update to 4.3makc2010-07-243-5/+57 * - Update to 2.4.0decke2010-07-233-6/+10 * - Update to 2.3.5decke2010-06-303-6/+6 * - Add missing patchfluffy2010-06-141-0/+11 * - Update finance/kmymoney-kde4 to 3.98.1fluffy2010-06-134-12/+9 * - Update to 5.0.11wen2010-06-134-8/+8 * - Reset maintainer to ports@FreeBSD.orgsahil2010-06-131-1/+1 * Fix plist when NOPORTDOCS is set.thierry2010-06-111-4/+4 * - Update to 0.71betalwhsu2010-06-094-76/+14 * Upgrade to 0.6.thierry2010-06-097-82/+374 * Update to 1.14.tobez2010-06-083-8/+11 * LICENSE GPLv2dinoex2010-06-041-0/+2 * - Update to 3.11.3wen2010-06-033-18/+31 * Bounce PORTREVISION for gettext-related ports. Have fun, ya'll.ade2010-05-3111-9/+11 * - drop USE_GNUSTEP_PREFIXdinoex2010-05-302-29/+28 * - Fix the depends error caused by remove of devel/py-rowen2010-05-251-2/+2 * - Update to 5.0.10wen2010-05-244-8/+8 * Update libical to 0.44.marcus2010-05-221-2/+2 * - Make pointyhat tinderbox happy by removing extra @dirrmry for common localefluffy2010-05-144-4/+2 * - Fix build on amd64pav2010-05-132-15/+24 * Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for thiskwm2010-05-111-2/+2 * - Handle extra oxygen 68x68 iconfluffy2010-05-041-0/+2 * [MAINTAINER] finance/kmymoney-kde4: Fix buildfluffy2010-05-041-1/+1 * - Attach kmymoney-kde4 to the buildfluffy2010-05-041-0/+1 * - finance/kmymoney-kde4: KDE4 version of KMyMoneyfluffy2010-05-04