aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc41/Makefile
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2003-12-15 15:45:53 +0800
committerobrien <obrien@FreeBSD.org>2003-12-15 15:45:53 +0800
commit816dfec8f1ab74cf6b5500a5971cf31de8d35403 (patch)
tree450fe2a1d2ba20e128cbc1bc407a8012a5d18f13 /lang/gcc41/Makefile
parent4cedcbaad0534940a018ed0241ac11a03d124893 (diff)
downloadfreebsd-ports-gnome-816dfec8f1ab74cf6b5500a5971cf31de8d35403.tar.gz
freebsd-ports-gnome-816dfec8f1ab74cf6b5500a5971cf31de8d35403.tar.zst
freebsd-ports-gnome-816dfec8f1ab74cf6b5500a5971cf31de8d35403.zip
* Deal with GCC's configurary's assumption that /usr/local/{include,lib}
are searched automatically by the compiler by using --with-libiconv-prefix. W/o --with-libiconv-prefix, 'configure' finds the lib, but not the header. During the make, neither will be found; a lot of inconsistency here... * Deal with GCC's configurary's brokenness WRT --with-libiconv-prefix due not actually passing the found header path to CFLAGS in any way.
Diffstat (limited to 'lang/gcc41/Makefile')
-rw-r--r--lang/gcc41/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/gcc41/Makefile b/lang/gcc41/Makefile
index d66f453c56cb..ff87f400dfda 100644
--- a/lang/gcc41/Makefile
+++ b/lang/gcc41/Makefile
@@ -52,6 +52,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BISON= yes
CONFIGURE_ARGS= --disable-nls \
+ --with-libiconv-prefix=${LOCALBASE} \
--with-gxx-include-dir=${TARGLIB}/include/c++/${GCC_REV}
#CONFIGURE_ARGS+= --program-suffix=34
# Java
@@ -78,6 +79,9 @@ MAN1= cpp34.1 g++34.1 g77-34.1 gcc34.1 gcov34.1 \
MAN7= fsf-funding.7 gfdl.7 gpl.7
INFO= cpp cppinternals g77 gcc gccinstall gccint gcj fastjar
+pre-everything::
+ @${ECHO_MSG} "Making GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL} ${PORTOBJFORMAT} target ${CONFIGURE_TARGET}"
+
.if defined(CVS_DATE)
NO_CHECKSUM= yes
DIST_SUBDIR= ${PKGNAME}