aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc41
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2006-09-17 10:05:25 +0800
committerkris <kris@FreeBSD.org>2006-09-17 10:05:25 +0800
commitc20fad92a6b2ea8875d11327cb45ad44a6ec0144 (patch)
treef89267067ce82d2b7b5c5774d03ab77372a4f78e /lang/gcc41
parent768c113d61ac55f6db81550f3975a89c28eb5b26 (diff)
downloadfreebsd-ports-gnome-c20fad92a6b2ea8875d11327cb45ad44a6ec0144.tar.gz
freebsd-ports-gnome-c20fad92a6b2ea8875d11327cb45ad44a6ec0144.tar.zst
freebsd-ports-gnome-c20fad92a6b2ea8875d11327cb45ad44a6ec0144.zip
Move the gcc4[12]-withgcjawt WITHOUT_JAVA BROKEN check into gcc41 since
it needs to happen after that variable is assigned in order to correctly function on !i386.
Diffstat (limited to 'lang/gcc41')
-rw-r--r--lang/gcc41/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/gcc41/Makefile b/lang/gcc41/Makefile
index dc66423ade20..1a7f526f72b3 100644
--- a/lang/gcc41/Makefile
+++ b/lang/gcc41/Makefile
@@ -72,6 +72,9 @@ CONFIGURE_ARGS+= --disable-nls \
CONFIGURE_ARGS+= --with-java-home=${PREFIX}/lib/jvm/java-1.4.2-gcj${SUFFIX}-1.4.2.0/jre \
--enable-java-awt=gtk,xlib \
--enable-gtk-cairo
+.if defined(WITHOUT_JAVA)
+BROKEN= Does not compile gcj
+.endif
.endif
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean