aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc43
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-02-01 23:24:32 +0800
committergerald <gerald@FreeBSD.org>2009-02-01 23:24:32 +0800
commit67ffb3ac6f37764878533c37f2832e95bc26a125 (patch)
tree47d2f6ae973ec256d2ecb01b0dadb742f1f21eda /lang/gcc43
parentece0ce16b59b4f2922ba01dd256d1b3f7e95162b (diff)
downloadfreebsd-ports-gnome-67ffb3ac6f37764878533c37f2832e95bc26a125.tar.gz
freebsd-ports-gnome-67ffb3ac6f37764878533c37f2832e95bc26a125.tar.zst
freebsd-ports-gnome-67ffb3ac6f37764878533c37f2832e95bc26a125.zip
Rename target check to regression-test [1], remove the post-build target
and its note on testing, add a conditional dependency on misc/dejagnu [1] and make the inclusion of gcc-testsuite in DISTFILES conditional, too. PR: 131185 Submitted by: Pedro F. Giffuni <giffunip@tutopia.com>
Diffstat (limited to 'lang/gcc43')
-rw-r--r--lang/gcc43/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/lang/gcc43/Makefile b/lang/gcc43/Makefile
index 9388e3e69a53..fb326cef9bd0 100644
--- a/lang/gcc43/Makefile
+++ b/lang/gcc43/Makefile
@@ -16,8 +16,7 @@ MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX} \
gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-objc-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
+ gcc-objc-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.3
@@ -25,6 +24,11 @@ COMMENT= GNU Compiler Collection 4.3
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
mpfr.3:${PORTSDIR}/math/mpfr
+.if defined(PACKAGE_BUILDING) || defined(MAINTAINER_MODE)
+DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
+BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
+.endif
+
SUFFIX= 43
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= alpha ia64 powerpc
@@ -155,12 +159,7 @@ pre-configure:
@${RM} -f ${SRCDIR}/gcc/*/*.info*
@${MKDIR} ${CONFIGURE_WRKSRC}
-post-build:
- @${ECHO_MSG} "Consider running 'make check' before 'make install', especially"
- @${ECHO_MSG} "if you have not performed this build on -STABLE or -CURRENT."
- @${ECHO_MSG} "This assumes that you have the dejagnu port installed."
-
-check: build
+regression-test: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install: