aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc44
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2005-06-14 08:45:24 +0800
committermaho <maho@FreeBSD.org>2005-06-14 08:45:24 +0800
commita1ffba56e55610d838ee8075f5465dfd1f3c75ed (patch)
tree24e55ca4322b98f1c83a9d7e455a342a5d42d708 /lang/gcc44
parent96c0d949c4e54261e5b7a1a3d991fdfef124b2a6 (diff)
downloadfreebsd-ports-gnome-a1ffba56e55610d838ee8075f5465dfd1f3c75ed.tar.gz
freebsd-ports-gnome-a1ffba56e55610d838ee8075f5465dfd1f3c75ed.tar.zst
freebsd-ports-gnome-a1ffba56e55610d838ee8075f5465dfd1f3c75ed.zip
A workaround to build libjava.
Approved by: gerald
Diffstat (limited to 'lang/gcc44')
-rw-r--r--lang/gcc44/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index 8b9668473442..51185c698658 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -54,16 +54,16 @@ CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64
WITHOUT_LIBJAVA= yes
.endif
-# FIXME: we are currently getting weird build failures on some 4.x and
-# 5.4 systems, which nobody has been able to track down yet. PR 81788.
-WITHOUT_LIBJAVA= yes
+# FIXME: we are currently getting weird build failures with libjava on
+# some 4.x and 5.x systems, which the following seems to work around. PR 81788.
+CONFIGURE_ARGS+= --disable-rpath
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 41
TARGLIB= ${PREFIX}/lib/gcc/${CONFIGURE_TARGET}/${PORTVERSION}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-nls \
+CONFIGURE_ARGS+= --disable-nls \
--with-system-zlib \
--with-libiconv-prefix=${LOCALBASE} \
--program-suffix=${SUFFIX} \