aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc45
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2004-03-17 22:21:58 +0800
committergerald <gerald@FreeBSD.org>2004-03-17 22:21:58 +0800
commit0c8f97a3b5897b32badc8fb0506b9386f055f6fc (patch)
tree9cf6558a1bd9fb1f669bb7420a6f888736ca7a5c /lang/gcc45
parentd41817a3e3c1bd72ba929a677eb5c4c6308eddf1 (diff)
downloadfreebsd-ports-gnome-0c8f97a3b5897b32badc8fb0506b9386f055f6fc.tar.gz
freebsd-ports-gnome-0c8f97a3b5897b32badc8fb0506b9386f055f6fc.tar.zst
freebsd-ports-gnome-0c8f97a3b5897b32badc8fb0506b9386f055f6fc.zip
Try to fix breakage of non-amd64 platforms introduced by 1.165 and
remove inflamatory comment. Remove BROKEN from sparc64 and simplify special case handling of libgcj on ia64 and sparc64. USE_SIZE is now the default, no need to specify it explicitly. Remove WANT_THREADS_SUPPORT knob, which should be a no-op by now.
Diffstat (limited to 'lang/gcc45')
-rw-r--r--lang/gcc45/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 8ff31da6c6b5..2a315db2fd2a 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -33,7 +33,6 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_REINPLACE= yes
-USE_SIZE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
@@ -42,16 +41,12 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-# fscking Linux & GNU $*!%
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
-.if ${ARCH} == sparc64
-BROKEN= "libgcj is not supported/packaging is broken on this platform"
-WITHOUT_LIBJAVA= yes
-.endif
-
-.if ${ARCH} == ia64
+.if ${ARCH} == ia64 || ${ARCH} == sparc64
WITHOUT_LIBJAVA= yes
.endif
@@ -74,11 +69,6 @@ EXTRA_SHLIB= libgcc_s
.else
CONFIGURE_ARGS+= --disable-shared
.endif
-.if defined(WANT_THREADS_SUPPORT)
-CONFIGURE_ARGS+= --enable-threads
-# ?is this an ObjC only thing?
-CONFIGURE_ARGS+= --enable-threads=posix
-.endif
ALL_TARGET= bootstrap-lean
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET}
MAN1= cpp${SUFFIX}.1 \