aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc47
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-04-11 23:21:23 +0800
committermat <mat@FreeBSD.org>2017-04-11 23:21:23 +0800
commitaf9c60625bda3e97370cc91b90ea306f292c209d (patch)
tree5a5d971bd61fde66fbaa1b8da9469708d182ffc8 /lang/gcc47
parente0cd3420489573ca501c588fae760fa3739e168c (diff)
downloadfreebsd-ports-gnome-af9c60625bda3e97370cc91b90ea306f292c209d.tar.gz
freebsd-ports-gnome-af9c60625bda3e97370cc91b90ea306f292c209d.tar.zst
freebsd-ports-gnome-af9c60625bda3e97370cc91b90ea306f292c209d.zip
Make defining both PORTVERSION and DISTVERSION a DEV_ERROR.
There are two cases: - The upstream versionning is compatible with our versionning, or using DISTVERSION's magic leads to a compatible PORTVERSION, use DISTVERSION. If it is possible to use DISTVERSIONPREFIX and DISTVERSIONSUFFIX to make it compatible, use them. - The upstream versionning is not compatible with our versionning, and DISTVERSION's magic does not lead to a correct PORTVERSION, then set PORTVERSION to the equivalent of our versionning, and set DISTNAME. It is possible to use a third variable where you store upstream's version and use it to compute PORTVERSION and/or DISTNAME, like the dns/bind9* ports do. Sponsored by: Absolight
Diffstat (limited to 'lang/gcc47')
-rw-r--r--lang/gcc47/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 02dcf2608372..3199e735ed61 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -6,7 +6,8 @@ PORTVERSION= 4.7.4
PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= lang java
-MASTER_SITES= GCC/releases/gcc-${DISTVERSION}
+MASTER_SITES= GCC/releases/gcc-${DIST_VERSION}
+DISTNAME= gcc-${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}
MAINTAINER= gerald@FreeBSD.org
@@ -27,9 +28,9 @@ BUILD_DEPENDS+= runtest:misc/dejagnu
CPE_VENDOR= gnu
-# DISTVERSION relates to downloads, GCC_VERSION and SUFFIX to names
+# DIST_VERSION relates to downloads, GCC_VERSION and SUFFIX to names
# of executables and directories once installed.
-DISTVERSION= ${PORTVERSION}
+DIST_VERSION= ${PORTVERSION}
GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 sparc64