aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc48/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2012-10-01 11:46:21 +0800
committergerald <gerald@FreeBSD.org>2012-10-01 11:46:21 +0800
commit792fdc09c27234aa7c96c0fc526477a078814885 (patch)
treeb484699fcebd13e027664174f226f25f65773078 /lang/gcc48/Makefile
parent7dd1402b6df76fbb9527fcb1e1adbfe40ed978c3 (diff)
downloadfreebsd-ports-gnome-792fdc09c27234aa7c96c0fc526477a078814885.tar.gz
freebsd-ports-gnome-792fdc09c27234aa7c96c0fc526477a078814885.tar.zst
freebsd-ports-gnome-792fdc09c27234aa7c96c0fc526477a078814885.zip
Forward port revision 282369 [1] which carried the following description:
On the way rename %%GCC_VER%% in pkg-plist to %%GCC_VERSION%% and make the Makefile machinery a bit more generic to minimize differences between lang/gcc ports based on releases and those based on snapshots. On the way, update to the 20120930 snapshot of GCC 4.8.0. Submitted by: jkim [1]
Diffstat (limited to 'lang/gcc48/Makefile')
-rw-r--r--lang/gcc48/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 25b6300386dc..2de4432dfdf4 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 4.8.0.20120909
+PORTVERSION= 4.8.0.20120930
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -20,7 +20,10 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
+# VERSIONSTRING relates to downloads, GCC_VERSION and SUFFIX to names
+# of executables and directories once installed.
VERSIONSTRING= ${PORTVERSION:C/([0-9]+\.[0-9]+).*\.([0-9]+)/\1-\2/}
+GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 sparc64
@@ -73,7 +76,7 @@ CONFIGURE_ARGS+=--disable-nls \
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
-PLIST_SUB= GCC_VER=${PORTVERSION:C/(.+)\.[0-9]+/\1/} \
+PLIST_SUB= GCC_VERSION=${GCC_VERSION} \
GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \