aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc48
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2005-09-02 17:31:27 +0800
committergerald <gerald@FreeBSD.org>2005-09-02 17:31:27 +0800
commit4fb132b5d2fab162713d7f9e981dd00ef060ffd8 (patch)
tree3be893df469330e3d04af693b6460331f1be8a31 /lang/gcc48
parented028326982bb9f886598628cb4b83b2cbd2f051 (diff)
downloadfreebsd-ports-gnome-4fb132b5d2fab162713d7f9e981dd00ef060ffd8.tar.gz
freebsd-ports-gnome-4fb132b5d2fab162713d7f9e981dd00ef060ffd8.tar.zst
freebsd-ports-gnome-4fb132b5d2fab162713d7f9e981dd00ef060ffd8.zip
Reenable the Java frontend and libgcj on i386. All build and installation
problems should be resolved now. Prevent running ranlib during installation to unbreak user mode installations which now install libraries with permissions 444. We now also need the math/mpfr port to build the Fortran frontend.[1] PR: 85495 [1]
Diffstat (limited to 'lang/gcc48')
-rw-r--r--lang/gcc48/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index d51a585f28c9..fbe48fe24c4b 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -23,6 +23,7 @@ COMMENT= GNU Compiler Collection 4.1
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+BUILD_DEPENDS= ${LOCALBASE}/lib/libmpfr.a:${PORTSDIR}/math/mpfr
.endif
CONFLICTS= gcc-3.3.* gcc-3.4.* gcc-4.0.*
@@ -44,7 +45,7 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
-.if ${ARCH} == i386 || ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64
+.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64
WITHOUT_JAVA= yes
.endif
@@ -65,6 +66,7 @@ CONFIGURE_ARGS+= --disable-nls \
--program-suffix=${SUFFIX} \
--libdir=${TARGLIB} \
--with-gxx-include-dir=${TARGLIB}/include/c++/
+CONFIGURE_ENV= RANLIB=:
.if defined(WITH_JAVA_AWT)
CONFIGURE_ARGS+= --enable-java-awt=xlib,gtk #--enable-gtk-cairo=yes
WANT_SHAREDLIBS=yes # We need this at the moment.