aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc48
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2005-07-20 18:49:51 +0800
committermaho <maho@FreeBSD.org>2005-07-20 18:49:51 +0800
commitaee76ce0c5554f4ab07d6889755bfddc53b6a152 (patch)
tree0821e702367fa7c4524c410890e2be97e8bf5362 /lang/gcc48
parent08a3b47412a6beac2a9f7c5aeeb5c47be237f236 (diff)
downloadfreebsd-ports-gnome-aee76ce0c5554f4ab07d6889755bfddc53b6a152.tar.gz
freebsd-ports-gnome-aee76ce0c5554f4ab07d6889755bfddc53b6a152.tar.zst
freebsd-ports-gnome-aee76ce0c5554f4ab07d6889755bfddc53b6a152.zip
o Java awt is now working via gtk20
o cairo is disabled since 0.5.0 is reqired
Diffstat (limited to 'lang/gcc48')
-rw-r--r--lang/gcc48/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index e7097a095692..4fb3f580a62b 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -29,6 +29,10 @@ COMMENT= GNU Compiler Collection 4.1
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
.endif
+.if defined(WITH_JAVA_AWT)
+LIB_DEPENDS+= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl2
+#LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo
+.endif
CONFLICTS= gcc-3.3.* gcc-3.4.* gcc-4.0.*
LATEST_LINK?= gcc41${PKGNAMESUFFIX}
@@ -38,6 +42,10 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_REINPLACE= yes
+.if defined(WITH_JAVA_AWT)
+USE_GNOME= gtk20
+USE_X11= yes
+.endif
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
@@ -72,6 +80,10 @@ CONFIGURE_ARGS+= --disable-nls \
.if defined(WITH_FORTRAN)
CONFIGURE_ARGS+= --with-gmp=${LOCALBASE}
.endif
+.if defined(WITH_JAVA_AWT)
+CONFIGURE_ARGS+= --enable-java-awt=xlib,gtk #--enable-gtk-cairo=yes
+WANT_SHAREDLIBS=yes #We need this atm
+.endif
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
.if defined(WANT_SHAREDLIBS)
CONFIGURE_ARGS+= --enable-shared