aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc6-aux
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-02-11 02:26:28 +0800
committermarino <marino@FreeBSD.org>2016-02-11 02:26:28 +0800
commit2021c1f238532fef83d7798228c3c3f8480ee645 (patch)
tree5d01517e5b455089a0954630e52b62d79424a1fd /lang/gcc6-aux
parentc3f152b95b3a4bdec02e4a799cf718f59dc9e8f7 (diff)
downloadfreebsd-ports-gnome-2021c1f238532fef83d7798228c3c3f8480ee645.tar.gz
freebsd-ports-gnome-2021c1f238532fef83d7798228c3c3f8480ee645.tar.zst
freebsd-ports-gnome-2021c1f238532fef83d7798228c3c3f8480ee645.zip
lang/gcc6-aux: Neutralize CPUTYPE settings
It's been reported that gcc6-aux fails to build when CPUTYPE is set to haswell and it's not alone. Remove any -march cflags which should effectively negate the CPUTYPE setting. We can't change CPUTYPE directly because it is included before the port makefile is.
Diffstat (limited to 'lang/gcc6-aux')
-rw-r--r--lang/gcc6-aux/Makefile.common1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/gcc6-aux/Makefile.common b/lang/gcc6-aux/Makefile.common
index 4f24cc2b0b03..64fff293ea61 100644
--- a/lang/gcc6-aux/Makefile.common
+++ b/lang/gcc6-aux/Makefile.common
@@ -12,3 +12,4 @@ GNU_CONFIGURE= yes
USES= gmake libtool perl5 tar:bzip2
USE_PERL5= build
ALL_TARGET= default
+CFLAGS:= ${CFLAGS:N-march=*}