aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc
diff options
context:
space:
mode:
authorjmmv <jmmv@FreeBSD.org>2015-11-09 04:09:59 +0800
committerjmmv <jmmv@FreeBSD.org>2015-11-09 04:09:59 +0800
commit209f7c5354459954440d5b07f02aab172650841d (patch)
tree4f057637df17829ca8031c2f30a223ba06c28582 /lang/gcc
parentd8b309c535d1ee8b89cc03c536ec8a0b1fe326e9 (diff)
downloadfreebsd-ports-gnome-209f7c5354459954440d5b07f02aab172650841d.tar.gz
freebsd-ports-gnome-209f7c5354459954440d5b07f02aab172650841d.tar.zst
freebsd-ports-gnome-209f7c5354459954440d5b07f02aab172650841d.zip
Add a MULTILIB option to gcc{,48,49,5} for powerpc64
This change is the same as r400632, which updated gcc[56]-devel, but now for gcc{,48,49,5}. Waited a week to ensure the change caused nothing to go horribly wrong but this change is very low risk because it only affects powerpc64. This fixes the build of gcc{,48,49,5} under powerpc64 when the system is built without the lib32 libraries. More in detail: If the system is built with lib32 support (WITH_LIB32, which is the default), building gcc from ports results in a compiler that can target both 64-bit and 32-bit binaries on powerpc64. However, when lib32 support is disabled (WITHOUT_LIB32), gcc should only be built with 64-bit support or otherwise the build fails. To fix this, explicitly disable 32-bit support when /usr/lib32 is not present and add a MULTILIB option (which is only defined for powerpc64 when 32-bit support is possible and defaults to yes to preserve the current behavior) to allow the user to explicitly control this feature. Approved by: gerald (maintainer), bdrewery (mentor), andreast Differential Revision: https://reviews.freebsd.org/D3952
Diffstat (limited to 'lang/gcc')
-rw-r--r--lang/gcc/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 3af4bab4c988..f67439703172 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gcc
PORTVERSION= 4.8.5
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= GCC/releases/gcc-${DISTVERSION}
@@ -46,6 +47,14 @@ OPTIONS_DEFAULT_i386= JAVA
OPTIONS_DEFAULT_amd64= JAVA
OPTIONS_EXCLUDE_DragonFly= JAVA
BOOTSTRAP_DESC= Build using a full bootstrap
+.if exists(/usr/lib32/libc.so)
+OPTIONS_DEFINE+= MULTILIB
+OPTIONS_DEFAULT+= MULTILIB
+MULTILIB_DESC= Build support for 32-bit and 64-bit target types
+MULTILIB_CONFIGURE_ENABLE= multilib
+.else
+CONFIGURE_ARGS+= --disable-multilib
+.endif
.include <bsd.port.pre.mk>