aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ghc
diff options
context:
space:
mode:
authorarrowd <arrowd@FreeBSD.org>2018-07-29 04:09:01 +0800
committerarrowd <arrowd@FreeBSD.org>2018-07-29 04:09:01 +0800
commit76b7a783d7cc190de6ca4c7d7b2e96c584243604 (patch)
treef7aa39c471f0aa7f3dfe289a4a3516746804c173 /lang/ghc
parent83c4ba5bf93a320aa7afa4a664bb7663fb7c0727 (diff)
downloadfreebsd-ports-gnome-76b7a783d7cc190de6ca4c7d7b2e96c584243604.tar.gz
freebsd-ports-gnome-76b7a783d7cc190de6ca4c7d7b2e96c584243604.tar.zst
freebsd-ports-gnome-76b7a783d7cc190de6ca4c7d7b2e96c584243604.zip
When deinstalling a Haskell package pass --no-user-package-db flag to ghc-pkg to avoid creation of ~/.ghc directory.
Reported by: tcberner Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D16480
Diffstat (limited to 'lang/ghc')
-rw-r--r--lang/ghc/bsd.cabal.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/ghc/bsd.cabal.mk b/lang/ghc/bsd.cabal.mk
index fe34b743e6e1..99dfea707c4e 100644
--- a/lang/ghc/bsd.cabal.mk
+++ b/lang/ghc/bsd.cabal.mk
@@ -325,7 +325,7 @@ add-plist-post: add-plist-cabal
add-plist-cabal:
. if !defined(STANDALONE)
- @${ECHO_CMD} '@postunexec ${LOCALBASE}/bin/ghc-pkg unregister --force ${PORTNAME}-${PORTVERSION}' >> ${TMPPLIST}
+ @${ECHO_CMD} '@postunexec ${LOCALBASE}/bin/ghc-pkg unregister --no-user-package-db --force ${PORTNAME}-${PORTVERSION}' >> ${TMPPLIST}
. endif
. if defined(HADDOCK_AVAILABLE) && ${PORT_OPTIONS:MDOCS}