aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gnat-gcc34/files
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2006-11-01 07:11:33 +0800
committerbsam <bsam@FreeBSD.org>2006-11-01 07:11:33 +0800
commit877f0114b02438bc41bea95aa3f3f12ea3fa2fc6 (patch)
tree3278252bcefc56aadefa784f5be5d590286a2e29 /lang/gnat-gcc34/files
parent085b29e23d5d25af07b2a0fe2b70565f6c32e98f (diff)
downloadfreebsd-ports-gnome-877f0114b02438bc41bea95aa3f3f12ea3fa2fc6.tar.gz
freebsd-ports-gnome-877f0114b02438bc41bea95aa3f3f12ea3fa2fc6.tar.zst
freebsd-ports-gnome-877f0114b02438bc41bea95aa3f3f12ea3fa2fc6.zip
- improved handling of include paths in the GCC build process; [1]
- proper care is taken that only the bootstrap compiler is used [1] (silences core dump messages in configure); - bump PORTREVISION. [1] PR: 104301 [2] Submitted by: Vaclav Haisman <v.haisman at sh.cvut.cz> [2] Karel Miklav <karel at lovetemple.net> (maintainer) [1]
Diffstat (limited to 'lang/gnat-gcc34/files')
-rw-r--r--lang/gnat-gcc34/files/patch-gcc-Makefile.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/lang/gnat-gcc34/files/patch-gcc-Makefile.in b/lang/gnat-gcc34/files/patch-gcc-Makefile.in
new file mode 100644
index 000000000000..675cb9b10580
--- /dev/null
+++ b/lang/gnat-gcc34/files/patch-gcc-Makefile.in
@@ -0,0 +1,20 @@
+--- gcc/Makefile.in.orig Wed Oct 25 18:03:23 2006
++++ gcc/Makefile.in Wed Oct 25 18:05:34 2006
+@@ -710,7 +710,7 @@
+ $(CFLAGS) $(INTERNAL_CFLAGS) $(COVERAGE_FLAGS) $(WARN_CFLAGS) $(XCFLAGS) @DEFS@
+
+ # Likewise.
+-ALL_CPPFLAGS = $(CPPFLAGS) $(X_CPPFLAGS) $(T_CPPFLAGS)
++ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS) $(X_CPPFLAGS) $(T_CPPFLAGS)
+
+ # Build and host support libraries. FORBUILD is either
+ # .. or ../$(build_alias) depending on whether host != build.
+@@ -758,7 +758,7 @@
+ -I$(srcdir)/../include @INCINTL@
+
+ .c.o:
+- $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) $(INCLUDES) $< $(OUTPUT_OPTION)
++ $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) $< $(OUTPUT_OPTION)
+
+ #
+ # Support for additional languages (other than C).