aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gnatcross-sysroot-aarch64
diff options
context:
space:
mode:
authorKoop Mast <kwm@rainbow-runner.nl>2017-02-08 15:45:16 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-02-08 15:45:16 +0800
commit8c10568a8bad15bd4e148e5298d61c75faa3c30d (patch)
tree8ec8a8ad03e47a7286399402357b1c326bf89c9d /lang/gnatcross-sysroot-aarch64
parentccabcd384d766804d3ce54b6a7ae1d257ce0fc11 (diff)
parent39324c127c7b2461bbbbbb06c5dd94442e997b46 (diff)
downloadfreebsd-ports-gnome-mate-1.16.tar.gz
freebsd-ports-gnome-mate-1.16.tar.zst
freebsd-ports-gnome-mate-1.16.zip
Merge branch 'master' into mate-1.16mate-1.16
Diffstat (limited to 'lang/gnatcross-sysroot-aarch64')
-rw-r--r--lang/gnatcross-sysroot-aarch64/Makefile44
-rw-r--r--lang/gnatcross-sysroot-aarch64/distinfo3
-rw-r--r--lang/gnatcross-sysroot-aarch64/pkg-descr4
3 files changed, 51 insertions, 0 deletions
diff --git a/lang/gnatcross-sysroot-aarch64/Makefile b/lang/gnatcross-sysroot-aarch64/Makefile
new file mode 100644
index 000000000000..25ea775ab920
--- /dev/null
+++ b/lang/gnatcross-sysroot-aarch64/Makefile
@@ -0,0 +1,44 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sysroot
+PORTVERSION= 1
+CATEGORIES= lang
+MASTER_SITES= ${PUB_FREEBSD}/releases/arm64/aarch64/11.0-RELEASE/:R11
+PKGNAMEPREFIX= gnatcross-
+PKGNAMESUFFIX= -aarch64
+DIST_SUBDIR= gnatcross/arm64-aarch64/${RELEASE}
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= FreeBSD sysroots for C/Ada cross-compiler (${ARCH})
+
+NO_BUILD= yes
+NO_MTREE= yes
+
+PUB_FREEBSD= ftp://ftp.freebsd.org/pub/FreeBSD
+PREFIX= ${LOCALBASE}/FreeBSD_ARM64
+
+ONLY_FOR_ARCHS= i386 amd64 # avoid aarch64 x aarch64
+EXTRACT_AFTER_ARGS= lib/ usr/include/ usr/lib/
+
+OPTIONS_SINGLE= SG1
+OPTIONS_SINGLE_SG1= RELEASE_11_0
+OPTIONS_DEFAULT= RELEASE_11_0
+
+RELEASE_11_0_DESC= FreeBSD 11.0 Release
+RELEASE_11_0_DISTFILES= base.txz:R11
+RELEASE_11_0_VARS= RELEASE=R11_0 CTARGET=aarch64-aux-freebsd11.0
+
+post-extract:
+ /bin/chflags -R noschg ${WRKDIR}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/sysroot
+ @${MV} ${WRKDIR}/lib ${STAGEDIR}${PREFIX}/sysroot
+ @${MV} ${WRKDIR}/usr ${STAGEDIR}${PREFIX}/sysroot
+ @echo ${CTARGET} > ${STAGEDIR}${PREFIX}/sysroot/target_triplet
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} sysroot -type d -empty -delete)
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} sysroot \( -type f -or -type l \) \
+ | ${SORT} >> ${TMPPLIST})
+
+.include <bsd.port.mk>
diff --git a/lang/gnatcross-sysroot-aarch64/distinfo b/lang/gnatcross-sysroot-aarch64/distinfo
new file mode 100644
index 000000000000..9af54e2a4d1f
--- /dev/null
+++ b/lang/gnatcross-sysroot-aarch64/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1486033400
+SHA256 (gnatcross/arm64-aarch64/R11_0/base.txz) = 16e9d744c39ef8ead3584815071a9086db10e71ef93e0108d5f490fe103b4bba
+SIZE (gnatcross/arm64-aarch64/R11_0/base.txz) = 78856068
diff --git a/lang/gnatcross-sysroot-aarch64/pkg-descr b/lang/gnatcross-sysroot-aarch64/pkg-descr
new file mode 100644
index 000000000000..94676c392f3a
--- /dev/null
+++ b/lang/gnatcross-sysroot-aarch64/pkg-descr
@@ -0,0 +1,4 @@
+This package is used by the lang/gnatcross-aarch64 Ada cross-compiler to
+install the system root of FreeBSD ARM64 (aarch64).
+
+WWW: http://www.dragonlace.net