aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gnatdroid-armv7
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2011-09-11 15:06:21 +0800
committerculot <culot@FreeBSD.org>2011-09-11 15:06:21 +0800
commit481d6ab753313298ba77b28ce6ba0d7de8a87bb8 (patch)
tree45fd5448b52b238786b098f221d2e63a8c96b624 /lang/gnatdroid-armv7
parent5ecdde00790ca77fdbd9d38df3bcaed7e4b22b35 (diff)
downloadfreebsd-ports-gnome-481d6ab753313298ba77b28ce6ba0d7de8a87bb8.tar.gz
freebsd-ports-gnome-481d6ab753313298ba77b28ce6ba0d7de8a87bb8.tar.zst
freebsd-ports-gnome-481d6ab753313298ba77b28ce6ba0d7de8a87bb8.zip
- Add patch to disable symbolic traceback run-time support
(could cause linker breakage) - Bump PORTREVISION PR: ports/160569 Submitted by: John Marino <draco@marino.st> (maintainer)
Diffstat (limited to 'lang/gnatdroid-armv7')
-rw-r--r--lang/gnatdroid-armv7/Makefile1
-rw-r--r--lang/gnatdroid-armv7/files/patch-gcc__ada__gccint__Makefile.in83
2 files changed, 84 insertions, 0 deletions
diff --git a/lang/gnatdroid-armv7/Makefile b/lang/gnatdroid-armv7/Makefile
index 5a9c167934d9..1dbd044761f9 100644
--- a/lang/gnatdroid-armv7/Makefile
+++ b/lang/gnatdroid-armv7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= armv7
PORTVERSION= 20110627
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://downloads.dragonlace.net/src/ \
http://dragonlace.mirrors.ada.cx/src/
diff --git a/lang/gnatdroid-armv7/files/patch-gcc__ada__gccint__Makefile.in b/lang/gnatdroid-armv7/files/patch-gcc__ada__gccint__Makefile.in
new file mode 100644
index 000000000000..b58767eb0006
--- /dev/null
+++ b/lang/gnatdroid-armv7/files/patch-gcc__ada__gccint__Makefile.in
@@ -0,0 +1,83 @@
+--- gcc/ada/gcc-interface/Makefile.in.orig 2011-09-07 16:11:58.000000000 -0500
++++ gcc/ada/gcc-interface/Makefile.in 2011-09-07 16:16:29.000000000 -0500
+@@ -1184,6 +1184,8 @@
+ a-numaux.ads<a-numaux-x86.ads \
+ g-bytswa.adb<g-bytswa-x86.adb \
+ g-socthi.adb<g-socthi-bsd.adb \
++ g-trasym.ads<g-trasym-unimplemented.ads \
++ g-trasym.adb<g-trasym-unimplemented.adb \
+ s-inmaop.adb<s-inmaop-posix.adb \
+ s-intman.adb<s-intman-posix.adb \
+ s-osinte.adb<s-osinte-freebsd.adb \
+@@ -1219,6 +1221,8 @@
+ a-numaux.ads<a-numaux-x86.ads \
+ g-bytswa.adb<g-bytswa-x86.adb \
+ g-socthi.adb<g-socthi-bsd.adb \
++ g-trasym.ads<g-trasym-unimplemented.ads \
++ g-trasym.adb<g-trasym-unimplemented.adb \
+ s-inmaop.adb<s-inmaop-posix.adb \
+ s-intman.adb<s-intman-posix.adb \
+ s-osinte.adb<s-osinte-freebsd.adb \
+@@ -1253,6 +1257,8 @@
+ a-numaux.ads<a-numaux-x86.ads \
+ g-bytswa.adb<g-bytswa-x86.adb \
+ g-socthi.adb<g-socthi-bsd.adb \
++ g-trasym.ads<g-trasym-unimplemented.ads \
++ g-trasym.adb<g-trasym-unimplemented.adb \
+ s-inmaop.adb<s-inmaop-posix.adb \
+ s-intman.adb<s-intman-posix.adb \
+ s-osinte.adb<s-osinte-dragonfly.adb \
+@@ -1288,6 +1294,8 @@
+ a-numaux.ads<a-numaux-x86.ads \
+ g-bytswa.adb<g-bytswa-x86.adb \
+ g-socthi.adb<g-socthi-bsd.adb \
++ g-trasym.ads<g-trasym-unimplemented.ads \
++ g-trasym.adb<g-trasym-unimplemented.adb \
+ s-inmaop.adb<s-inmaop-posix.adb \
+ s-intman.adb<s-intman-posix.adb \
+ s-osinte.adb<s-osinte-dragonfly.adb \
+@@ -1322,6 +1330,8 @@
+ a-numaux.ads<a-numaux-x86.ads \
+ g-bytswa.adb<g-bytswa-x86.adb \
+ g-socthi.adb<g-socthi-bsd.adb \
++ g-trasym.ads<g-trasym-unimplemented.ads \
++ g-trasym.adb<g-trasym-unimplemented.adb \
+ s-inmaop.adb<s-inmaop-posix.adb \
+ s-intman.adb<s-intman-posix.adb \
+ s-osinte.adb<s-osinte-openbsd.adb \
+@@ -1357,6 +1367,8 @@
+ a-numaux.ads<a-numaux-x86.ads \
+ g-bytswa.adb<g-bytswa-x86.adb \
+ g-socthi.adb<g-socthi-bsd.adb \
++ g-trasym.ads<g-trasym-unimplemented.ads \
++ g-trasym.adb<g-trasym-unimplemented.adb \
+ s-inmaop.adb<s-inmaop-posix.adb \
+ s-intman.adb<s-intman-posix.adb \
+ s-osinte.adb<s-osinte-openbsd.adb \
+@@ -1391,6 +1403,8 @@
+ a-numaux.ads<a-numaux-x86.ads \
+ g-bytswa.adb<g-bytswa-x86.adb \
+ g-socthi.adb<g-socthi-netbsd.adb \
++ g-trasym.ads<g-trasym-unimplemented.ads \
++ g-trasym.adb<g-trasym-unimplemented.adb \
+ s-inmaop.adb<s-inmaop-posix.adb \
+ s-intman.adb<s-intman-posix.adb \
+ s-osinte.adb<s-osinte-netbsd.adb \
+@@ -1435,6 +1449,8 @@
+ a-numaux.ads<a-numaux-x86.ads \
+ g-bytswa.adb<g-bytswa-x86.adb \
+ g-socthi.adb<g-socthi-netbsd.adb \
++ g-trasym.ads<g-trasym-unimplemented.ads \
++ g-trasym.adb<g-trasym-unimplemented.adb \
+ s-inmaop.adb<s-inmaop-posix.adb \
+ s-intman.adb<s-intman-posix.adb \
+ s-osinte.adb<s-osinte-netbsd.adb \
+@@ -1472,6 +1488,8 @@
+ ifeq ($(strip $(filter-out arm% android eabi,$(targ))),)
+ LIBGNAT_TARGET_PAIRS = \
+ a-intnam.ads<a-intnam-linux.ads \
++ g-trasym.ads<g-trasym-unimplemented.ads \
++ g-trasym.adb<g-trasym-unimplemented.adb \
+ s-inmaop.adb<s-inmaop-posix.adb \
+ s-intman.adb<s-intman-posix.adb \
+ s-linux.ads<s-linux.ads \