aboutsummaryrefslogtreecommitdiffstats
path: root/lang/go14
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-04-21 18:02:27 +0800
committerMartin Wilke <miwi@FreeBSD.org>2017-04-21 18:02:27 +0800
commitf51091ad5956e3a411b095aef4fd3b11d62dc2c2 (patch)
treee1a584f33191eb6dd5c6578b6b3c6130b3637c27 /lang/go14
parentf450275829895d5bc7b05b5c23e6deffc3c35b34 (diff)
downloadfreebsd-ports-gnome-f51091ad5956e3a411b095aef4fd3b11d62dc2c2.tar.gz
freebsd-ports-gnome-f51091ad5956e3a411b095aef4fd3b11d62dc2c2.tar.zst
freebsd-ports-gnome-f51091ad5956e3a411b095aef4fd3b11d62dc2c2.zip
- Fix shebangs
- Fix bin/rc in lang/go since we dont have it in base or a port to support it - While in lang/go remove WRKSRC for SHEBANG_FILES - Bump PORTREVISION for package change
Diffstat (limited to 'lang/go14')
-rw-r--r--lang/go14/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/lang/go14/Makefile b/lang/go14/Makefile
index ae4c13689917..b153a52d7821 100644
--- a/lang/go14/Makefile
+++ b/lang/go14/Makefile
@@ -2,7 +2,7 @@
PORTNAME= go14
PORTVERSION= 1.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= http://golang.org/dl/
DISTNAME= go${PORTVERSION}.src
@@ -13,11 +13,16 @@ COMMENT= Go programming language
LICENSE= BSD3CLAUSE
USES= compiler shebangfix
-SHEBANG_LANG= sh
-SHEBANG_FILES= ${WRKSRC}/src/*.bash \
- ${WRKSRC}/doc/progs/run \
- ${WRKSRC}/doc/articles/wiki/*.bash \
- ${WRKSRC}/test/bench/shootout/timing.sh
+SHEBANG_LANG= sh perl
+SHEBANG_FILES= src/*.bash \
+ src/cmd/go/*.bash \
+ doc/progs/run \
+ doc/articles/wiki/*.bash \
+ test/bench/shootout/timing.sh \
+ misc/nacl/*_exec misc/benchcmp \
+ src/net/http/cgi/testdata/*.cgi \
+ src/regexp/syntax/*.pl \
+ lib/codereview/*.sh
sh_OLD_CMD= "/usr/bin/env bash"
sh_CMD= ${SH}