aboutsummaryrefslogtreecommitdiffstats
path: root/lang/harbour/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2009-08-15 16:32:15 +0800
committerMark Linimon <linimon@FreeBSD.org>2009-08-15 16:32:15 +0800
commitb1ea55b55df9b4dd8378b1b4a63a1218af74e9b3 (patch)
tree7a710cfac9356fe565b6b4cad833c93c217b32e7 /lang/harbour/Makefile
parent68ce7e4d6dee34d1ae9bb0277dee73739d8b59c8 (diff)
downloadfreebsd-ports-gnome-b1ea55b55df9b4dd8378b1b4a63a1218af74e9b3.tar.gz
freebsd-ports-gnome-b1ea55b55df9b4dd8378b1b4a63a1218af74e9b3.tar.zst
freebsd-ports-gnome-b1ea55b55df9b4dd8378b1b4a63a1218af74e9b3.zip
Mark as broken on amd64 (leaves files behind on deinstall), and sparc64
(fails to compile). Hat: portmgr
Diffstat (limited to 'lang/harbour/Makefile')
-rw-r--r--lang/harbour/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/lang/harbour/Makefile b/lang/harbour/Makefile
index d1dbd99ca77e..ab0ce3ed494f 100644
--- a/lang/harbour/Makefile
+++ b/lang/harbour/Makefile
@@ -42,7 +42,7 @@ MAKE_ENV+= HB_ARCHITECTURE=${HB_ARCHITECTURE} \
HB_WITHOUT_X11=${HB_WITHOUT_X11}
.if !defined(NOPORTDOCS)
-MAKE_ENV+= HB_DOC_INSTALL=${HB_DOC_INSTALL}
+MAKE_ENV+= HB_DOC_INSTALL=${HB_DOC_INSTALL}
.endif
PORTDOCS= *.txt genhtm.bat genhtm.lnk genhtm.rsp
@@ -55,4 +55,12 @@ pre-install:
${MKDIR} ${DOCSDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= Leaves files behind on deinstall
+.elif ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64: assertion failed
+.endif
+
+.include <bsd.port.post.mk>