aboutsummaryrefslogtreecommitdiffstats
path: root/lang/io/Makefile.addons
diff options
context:
space:
mode:
authorKoop Mast <kwm@rainbow-runner.nl>2017-09-15 15:12:44 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-09-15 15:12:44 +0800
commitab1f40794d9dbcc1388a9257d285362f52f74596 (patch)
tree2a6a7e2dc039c429914eaca76a443556bf403df2 /lang/io/Makefile.addons
parentfd6770ac21bfbaf4055314e3e44262e074d8043b (diff)
parent26f34f6d62441f81a8d0d43f1908a496c283ee05 (diff)
downloadfreebsd-ports-gnome-gnome-3.24.tar.gz
freebsd-ports-gnome-gnome-3.24.tar.zst
freebsd-ports-gnome-gnome-3.24.zip
Merge branch 'master' into gnome-3.24gnome-3.24
Diffstat (limited to 'lang/io/Makefile.addons')
-rw-r--r--lang/io/Makefile.addons5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/io/Makefile.addons b/lang/io/Makefile.addons
index da921ad16c7f..1f3c52cf92c8 100644
--- a/lang/io/Makefile.addons
+++ b/lang/io/Makefile.addons
@@ -17,6 +17,7 @@ DEFAULT_ADDONS= AsyncRequest \
Loki \
MD5 \
NotificationCenter \
+ Oauth \
Obsidian \
Random \
Range \
@@ -39,6 +40,7 @@ DEFAULT_ADDONS= AsyncRequest \
#
OPTIONAL_ADDONS=BigNum \
CFFI \
+ Cairo \
Clutter \
DBI \
EditLine \
@@ -72,6 +74,7 @@ OPTIONS_GROUP_ADDONS=${OPTIONAL_ADDONS}
BigNum_LIB_DEPENDS= libgmp.so:math/gmp
CFFI_LIB_DEPENDS= libffi.so:devel/libffi
+Cairo_USE= GNOME=cairo
Clutter_LIB_DEPENDS= libclutter-glx-1.0.so:graphics/clutter
DBI_LIB_DEPENDS= libdbi.so:databases/libdbi
EditLine_USES= libedit
@@ -92,7 +95,7 @@ MySQL_USES= mysql:client
Ogg_LIB_DEPENDS= libogg.so:audio/libogg
OpenGL_USE= GL=glut XORG=xmu
PostgreSQL_USES= pgsql
-Python_USES= python
+Python_USES= python:3.3+
QDBM_LIB_DEPENDS= libqdbm.so:databases/qdbm
ReadLine_USES= readline:port
Regex_LIB_DEPENDS= libpcre.so:devel/pcre