aboutsummaryrefslogtreecommitdiffstats
path: root/lang/io/files
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2017-09-14 20:41:16 +0800
committergahr <gahr@FreeBSD.org>2017-09-14 20:41:16 +0800
commite8b88da640bb4b187b3c1eb448a010309be70f01 (patch)
tree9c68e7c639842aa7ffeeff8b363ceb0e837b55a7 /lang/io/files
parent6dff9b23ea85909d34b234bc8b990365884f860f (diff)
downloadfreebsd-ports-gnome-e8b88da640bb4b187b3c1eb448a010309be70f01.tar.gz
freebsd-ports-gnome-e8b88da640bb4b187b3c1eb448a010309be70f01.tar.zst
freebsd-ports-gnome-e8b88da640bb4b187b3c1eb448a010309be70f01.zip
lang/io: unbreak on i386
Diffstat (limited to 'lang/io/files')
-rw-r--r--lang/io/files/patch-CMakeLists.txt11
-rw-r--r--lang/io/files/patch-addons_Oauth_source_Oauth_crypto.c11
-rw-r--r--lang/io/files/patch-addons_Oauth_source_Oauth_crypto.h11
-rw-r--r--lang/io/files/patch-libs_iovm_source_IoVersion.h2
4 files changed, 34 insertions, 1 deletions
diff --git a/lang/io/files/patch-CMakeLists.txt b/lang/io/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..294032df57d0
--- /dev/null
+++ b/lang/io/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2017-08-11 18:47:18 UTC
++++ CMakeLists.txt
+@@ -35,7 +35,7 @@ endif()
+ project(IoLanguage)
+
+ # Default config when building with gcc variants
+-IF(CMAKE_COMPILER_IS_GNUCC)
++IF(CMAKE_COMPILER_IS_GNUCC OR (CMAKE_C_COMPILER_ID MATCHES "Clang"))
+ SET(CMAKE_BUILD_TYPE_DebugFast)
+ SET(CMAKE_CXX_FLAGS_DEBUGFAST "-g -O0")
+ SET(CMAKE_C_FLAGS_DEBUGFAST "-g -O0")
diff --git a/lang/io/files/patch-addons_Oauth_source_Oauth_crypto.c b/lang/io/files/patch-addons_Oauth_source_Oauth_crypto.c
new file mode 100644
index 000000000000..1ae4f1ea54e8
--- /dev/null
+++ b/lang/io/files/patch-addons_Oauth_source_Oauth_crypto.c
@@ -0,0 +1,11 @@
+--- addons/Oauth/source/Oauth/crypto.c.orig 2017-09-14 12:29:48 UTC
++++ addons/Oauth/source/Oauth/crypto.c
+@@ -658,7 +658,7 @@ void sha1_finalize(struct sha1_context *
+ sha1_update(self, bits, 8);
+
+ /* Store state in digest */
+- SHA1Encode(digest, (uint32_t *)self->state, 20);
++ SHA1Encode(digest, self->state, 20);
+
+ /* Zeroize sensitive information.
+ */
diff --git a/lang/io/files/patch-addons_Oauth_source_Oauth_crypto.h b/lang/io/files/patch-addons_Oauth_source_Oauth_crypto.h
new file mode 100644
index 000000000000..62f54e16d7b1
--- /dev/null
+++ b/lang/io/files/patch-addons_Oauth_source_Oauth_crypto.h
@@ -0,0 +1,11 @@
+--- addons/Oauth/source/Oauth/crypto.h.orig 2017-09-14 12:33:11 UTC
++++ addons/Oauth/source/Oauth/crypto.h
+@@ -16,7 +16,7 @@ struct md5_context
+
+ struct sha1_context
+ {
+- unsigned long state[5];
++ uint32_t state[5];
+ unsigned long count[2];
+ unsigned char buffer[64];
+ };
diff --git a/lang/io/files/patch-libs_iovm_source_IoVersion.h b/lang/io/files/patch-libs_iovm_source_IoVersion.h
index 77eef9bd9992..342a0ed8dfac 100644
--- a/lang/io/files/patch-libs_iovm_source_IoVersion.h
+++ b/lang/io/files/patch-libs_iovm_source_IoVersion.h
@@ -1,4 +1,4 @@
---- libs/iovm/source/IoVersion.h.orig 2017-09-13 11:47:59 UTC
+--- libs/iovm/source/IoVersion.h.orig 2017-08-11 18:47:18 UTC
+++ libs/iovm/source/IoVersion.h
@@ -1,3 +1,3 @@
#ifndef IO_VERSION_STRING