aboutsummaryrefslogtreecommitdiffstats
path: root/lang/itcl
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-12-26 22:19:04 +0800
committerthierry <thierry@FreeBSD.org>2005-12-26 22:19:04 +0800
commitfc1515d79724d175b51bda4178ffa7fa210707bd (patch)
tree8c06b1a880eb05256ff6f2018ed14783001b829e /lang/itcl
parent71c9a7ebb7c1cd57a3070bf4ad455984c07e1a36 (diff)
downloadfreebsd-ports-gnome-fc1515d79724d175b51bda4178ffa7fa210707bd.tar.gz
freebsd-ports-gnome-fc1515d79724d175b51bda4178ffa7fa210707bd.tar.zst
freebsd-ports-gnome-fc1515d79724d175b51bda4178ffa7fa210707bd.zip
Updates to use tcl84.
Bump PORTREVISION and add tcl84 to CATEGORIES. PR: N/A (direct mail) Submitted by: Pedro F. Giffuni <giffunip (at) yahoo.com>
Diffstat (limited to 'lang/itcl')
-rw-r--r--lang/itcl/Makefile11
-rw-r--r--lang/itcl/files/Makefile.lib4
-rw-r--r--lang/itcl/files/patch+generic+itcl_class.c11
-rw-r--r--lang/itcl/files/patch-generic+itcl_cmds.c11
4 files changed, 30 insertions, 7 deletions
diff --git a/lang/itcl/Makefile b/lang/itcl/Makefile
index 172364d17076..4943bd12fede 100644
--- a/lang/itcl/Makefile
+++ b/lang/itcl/Makefile
@@ -7,7 +7,8 @@
PORTNAME= itcl
PORTVERSION= ${MAJOR}.${MINOR}.1
-CATEGORIES= lang
+PORTREVISION= 1
+CATEGORIES= lang tcl84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=incrtcl
DISTNAME= itcl${PORTVERSION}
@@ -16,13 +17,13 @@ EXTRACT_SUFX= _src.tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= [incr Tcl] (A.K.A. "itcl")
-LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83
+LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84
WRKSRC= ${WRKDIR}/${DISTNAME}/itcl
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-PKGINSTALL= ${PORTSDIR}/lang/tcl83/pkg-install.tclsh
-PKGDEINSTALL= ${PORTSDIR}/lang/tcl83/pkg-deinstall.tclsh
+PKGINSTALL= ${PORTSDIR}/lang/tcl84/pkg-install.tclsh
+PKGDEINSTALL= ${PORTSDIR}/lang/tcl84/pkg-deinstall.tclsh
MAKE_ENV+= ${PLIST_SUB} \
SHLIB_MAJOR=${SHLIB_MAJOR} SHLIB_MINOR=${SHLIB_MINOR}
@@ -54,7 +55,7 @@ post-patch:
post-build test:
cd ${WRKSRC} && ${SETENV} ITCL_LIBRARY=${WRKSRC}/library \
- ${PREFIX}/bin/tclsh8.3 tests/all.tcl
+ ${PREFIX}/bin/tclsh8.4 tests/all.tcl
post-install:
${INSTALL_DATA} ${WRKSRC}/doc/*.n ${PREFIX}/man/mann/
diff --git a/lang/itcl/files/Makefile.lib b/lang/itcl/files/Makefile.lib
index de65a293d51f..83e2f77022ba 100644
--- a/lang/itcl/files/Makefile.lib
+++ b/lang/itcl/files/Makefile.lib
@@ -2,7 +2,7 @@ NOPROFILE= yes
LIB= itcl${MAJOR}${MINOR}
ITCL_LIBRARY= ${PREFIX}/lib/itcl${MAJOR}.${MINOR}
CFLAGS+= -I. -I./../generic \
- -I${PREFIX}/include/tcl8.3/generic \
+ -I${PREFIX}/include/tcl8.4/generic \
-DHAVE_GETCWD=1 -DNO_VALUES_H=1 -DHAVE_UNISTD_H=1 -DUSE_TERMIOS=1\
-DHAVE_SYS_TIME_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_TM_ZONE=1\
-DHAVE_TM_GMTOFF=1 -DHAVE_ST_BLKSIZE=1 -DSTDC_HEADERS=1\
@@ -11,7 +11,7 @@ CFLAGS+= -I. -I./../generic \
-DHAVE_SYS_FILIO_H=1 \
-DRETSIGTYPE=void \
-DITCL_LIBRARY=\"${ITCL_LIBRARY}\"
-LDADD+= -L${PREFIX}/lib -ltcl83
+LDADD+= -L${PREFIX}/lib -ltcl84
.PATH: ${.CURDIR}/unix ${.CURDIR}/generic ${.CURDIR}/man
diff --git a/lang/itcl/files/patch+generic+itcl_class.c b/lang/itcl/files/patch+generic+itcl_class.c
new file mode 100644
index 000000000000..4aca04af2cf5
--- /dev/null
+++ b/lang/itcl/files/patch+generic+itcl_class.c
@@ -0,0 +1,11 @@
+--- generic/itcl_class.c.orig Mon May 21 20:35:38 2001
++++ generic/itcl_class.c Sun Dec 25 15:28:16 2005
+@@ -732,7 +732,7 @@
+ /* flags */ 0);
+
+ if ( !classNs && contextNs->parentPtr != NULL &&
+- (*path != ':' || *(path+1) != ':') ) {
++ (strncmp(path, "::", 2) != 0) ) {
+
+ if (strcmp(contextNs->name, path) == 0) {
+ classNs = contextNs;
diff --git a/lang/itcl/files/patch-generic+itcl_cmds.c b/lang/itcl/files/patch-generic+itcl_cmds.c
index 34d8905683e9..d6c48a9b32dd 100644
--- a/lang/itcl/files/patch-generic+itcl_cmds.c
+++ b/lang/itcl/files/patch-generic+itcl_cmds.c
@@ -209,3 +209,14 @@ diff -u -r1.13 -r1.15
cdefn = Itcl_FindClass(interp, name, /* autoload */ 0);
if (cdefn) {
+--- generic/itcl_cmds.c.orig Sun Dec 25 15:16:04 2005
++++ generic/itcl_cmds.c Sun Dec 25 15:28:16 2005
+@@ -996,7 +996,7 @@
+ * then return it as is.
+ */
+ token = Tcl_GetStringFromObj(objv[1], (int*)NULL);
+- if (*token == ':' && *(token+1) == ':') {
++ if (strncmp(token, "::", 2) == 0) {
+ Tcl_SetObjResult(interp, objv[1]);
+ return TCL_OK;
+ }