aboutsummaryrefslogtreecommitdiffstats
path: root/lang/klone
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2012-12-03 20:55:00 +0800
committergahr <gahr@FreeBSD.org>2012-12-03 20:55:00 +0800
commit5911602b7e223c124ffc89da4f4ac93d24eda931 (patch)
treedd474d9ce93a740e7325e6b0a4ecca16570ecaf2 /lang/klone
parentcbff425852c38c5592cb286803993d3e35043fea (diff)
downloadfreebsd-ports-gnome-5911602b7e223c124ffc89da4f4ac93d24eda931.tar.gz
freebsd-ports-gnome-5911602b7e223c124ffc89da4f4ac93d24eda931.tar.zst
freebsd-ports-gnome-5911602b7e223c124ffc89da4f4ac93d24eda931.zip
- Fix build with clang
- Trim Makefile header Feature safe: yes
Diffstat (limited to 'lang/klone')
-rw-r--r--lang/klone/Makefile6
-rw-r--r--lang/klone/files/patch-klos.c31
-rw-r--r--lang/klone/files/patch-klregexp.c19
3 files changed, 51 insertions, 5 deletions
diff --git a/lang/klone/Makefile b/lang/klone/Makefile
index cc58becb761f..cd07c5c83df6 100644
--- a/lang/klone/Makefile
+++ b/lang/klone/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: klone
-# Date created: 23 Aug 2001
-# Whom: Kris Kennaway <kris@FreeBSD.org>
-#
+# Created by: Kris Kennaway <kris@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= klone
PORTVERSION= 2.1.359
diff --git a/lang/klone/files/patch-klos.c b/lang/klone/files/patch-klos.c
new file mode 100644
index 000000000000..530d3e2e000f
--- /dev/null
+++ b/lang/klone/files/patch-klos.c
@@ -0,0 +1,31 @@
+--- klos.c.orig 2012-12-03 13:51:56.000000000 +0100
++++ klos.c 2012-12-03 13:53:25.000000000 +0100
+@@ -83,9 +83,12 @@
+ #define KlWaitPid(statusp) wait3(statusp, WNOHANG, 0)
+ #endif
+
++
+ DECLARE_strchr;
+
+ KlRSignal KlChildDeathHandler();
++void KlSignalHandlerExecuteAux(int, KlO);
++void KlProcessIdDies(int, int);
+
+ /* On SYSV signals where it is possible (AIX), use an emulation of the BSD
+ * signal call via sigaction.
+@@ -777,6 +780,7 @@
+
+ /* a process is signalled to be dead */
+
++void
+ KlProcessIdDies(pid, status)
+ int pid;
+ int status;
+@@ -1591,6 +1595,7 @@
+ #endif
+ }
+
++void
+ KlSignalHandlerExecuteAux(sig, handler)
+ int sig;
+ KlO handler;
diff --git a/lang/klone/files/patch-klregexp.c b/lang/klone/files/patch-klregexp.c
new file mode 100644
index 000000000000..16232339535b
--- /dev/null
+++ b/lang/klone/files/patch-klregexp.c
@@ -0,0 +1,19 @@
+--- klregexp.c.orig 2012-12-03 13:50:10.000000000 +0100
++++ klregexp.c 2012-12-03 13:51:40.000000000 +0100
+@@ -208,6 +208,8 @@
+ STATIC int strcspn();
+ #endif
+
++void Klparnum_add(int, int, char *);
++
+ /*
+ - regcomp - compile a regular expression into internal code
+ *
+@@ -1302,6 +1304,7 @@
+ * we maintain a p-list of parenleven, offset in program
+ */
+
++void
+ Klparnum_add(type, parno, ptr)
+ int type; /* OPEN or CLOSE */
+ int parno;