aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ldc
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-06-03 14:31:09 +0800
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-06-03 14:31:09 +0800
commiteac9c1f02337e23b73d78b8b391fb107963ab4b2 (patch)
tree29e23e7d0f77b429294a4c314afe992b4590afc4 /lang/ldc
parent8e590d32788e74b4f051c93693255560d6b6bd09 (diff)
downloadfreebsd-ports-gnome-eac9c1f02337e23b73d78b8b391fb107963ab4b2.tar.gz
freebsd-ports-gnome-eac9c1f02337e23b73d78b8b391fb107963ab4b2.tar.zst
freebsd-ports-gnome-eac9c1f02337e23b73d78b8b391fb107963ab4b2.zip
- Update to 1.9.0 (jit support was dropped with llvm < 5.0). It doesn't compile
with llvm 5.x on FreeBSD
Diffstat (limited to 'lang/ldc')
-rw-r--r--lang/ldc/Makefile4
-rw-r--r--lang/ldc/distinfo6
-rw-r--r--lang/ldc/pkg-plist45
3 files changed, 33 insertions, 22 deletions
diff --git a/lang/ldc/Makefile b/lang/ldc/Makefile
index 41ab00740b3e..c5e6a9be5d3f 100644
--- a/lang/ldc/Makefile
+++ b/lang/ldc/Makefile
@@ -1,9 +1,7 @@
-# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
PORTNAME= ldc
-PORTVERSION= 1.7.0
-PORTREVISION= 2
+PORTVERSION= 1.9.0
CATEGORIES= lang
MASTER_SITES= https://github.com/ldc-developers/ldc/releases/download/v${PORTVERSION}/:source \
https://github.com/ldc-developers/ldc/releases/download/v${BOOTVER}/:bootstrap
diff --git a/lang/ldc/distinfo b/lang/ldc/distinfo
index 7bd19ca2d7e7..91a98576abb0 100644
--- a/lang/ldc/distinfo
+++ b/lang/ldc/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1517340071
-SHA256 (ldc-1.7.0-src.tar.gz) = 7cd46140ca3e4ca0d52c352e5b694d4d5336898ed4f02c3e18e0eafd69dd18bd
-SIZE (ldc-1.7.0-src.tar.gz) = 6529435
+TIMESTAMP = 1525807496
+SHA256 (ldc-1.9.0-src.tar.gz) = e3f32a4dfcaae12f434e0e23638684faa83765827e7f2deb2df059dccc3169b9
+SIZE (ldc-1.9.0-src.tar.gz) = 6560330
SHA256 (ldc-0.17.5-src.tar.gz) = 7aa540a135f9fa1ee9722cad73100a8f3600a07f9a11d199d8be68887cc90008
SIZE (ldc-0.17.5-src.tar.gz) = 5006161
diff --git a/lang/ldc/pkg-plist b/lang/ldc/pkg-plist
index b35ccd015e85..2fb972b4cb52 100644
--- a/lang/ldc/pkg-plist
+++ b/lang/ldc/pkg-plist
@@ -15,6 +15,7 @@ include/d/core/internal/abort.d
include/d/core/internal/arrayop.d
include/d/core/internal/convert.d
include/d/core/internal/hash.d
+include/d/core/internal/parseoptions.d
include/d/core/internal/spinlock.d
include/d/core/internal/string.d
include/d/core/internal/traits.d
@@ -70,6 +71,21 @@ include/d/core/sys/darwin/pthread.d
include/d/core/sys/darwin/sys/cdefs.d
include/d/core/sys/darwin/sys/event.d
include/d/core/sys/darwin/sys/mman.d
+include/d/core/sys/dragonflybsd/dlfcn.d
+include/d/core/sys/dragonflybsd/execinfo.d
+include/d/core/sys/dragonflybsd/netinet/in_.d
+include/d/core/sys/dragonflybsd/pthread_np.d
+include/d/core/sys/dragonflybsd/sys/_bitset.d
+include/d/core/sys/dragonflybsd/sys/_cpuset.d
+include/d/core/sys/dragonflybsd/sys/cdefs.d
+include/d/core/sys/dragonflybsd/sys/elf.d
+include/d/core/sys/dragonflybsd/sys/elf32.d
+include/d/core/sys/dragonflybsd/sys/elf64.d
+include/d/core/sys/dragonflybsd/sys/elf_common.d
+include/d/core/sys/dragonflybsd/sys/event.d
+include/d/core/sys/dragonflybsd/sys/link_elf.d
+include/d/core/sys/dragonflybsd/sys/mman.d
+include/d/core/sys/dragonflybsd/time.d
include/d/core/sys/freebsd/dlfcn.d
include/d/core/sys/freebsd/execinfo.d
include/d/core/sys/freebsd/netinet/in_.d
@@ -385,7 +401,6 @@ include/d/ldc/arrayinit.d
include/d/ldc/asan.d
include/d/ldc/attributes.d
include/d/ldc/dcompute.d
-include/d/ldc/dynamic_compile.d
include/d/ldc/eh_asm.S
include/d/ldc/eh_msvc.d
include/d/ldc/gccbuiltins_aarch64.di
@@ -396,10 +411,11 @@ include/d/ldc/gccbuiltins_s390.di
include/d/ldc/gccbuiltins_x86.di
include/d/ldc/internal/vararg.di
include/d/ldc/intrinsics.di
+include/d/ldc/libfuzzer.di
include/d/ldc/llvmasm.di
include/d/ldc/msvc.c
include/d/ldc/object.d
-include/d/ldc/profile.d
+include/d/ldc/profile.di
include/d/ldc/simd.di
include/d/std/algorithm/comparison.d
include/d/std/algorithm/internal.d
@@ -466,8 +482,10 @@ include/d/std/digest/ripemd.d
include/d/std/digest/sha.d
include/d/std/encoding.d
include/d/std/exception.d
+include/d/std/experimental/all.d
include/d/std/experimental/allocator/building_blocks/affix_allocator.d
include/d/std/experimental/allocator/building_blocks/allocator_list.d
+include/d/std/experimental/allocator/building_blocks/ascending_page_allocator.d
include/d/std/experimental/allocator/building_blocks/bitmapped_block.d
include/d/std/experimental/allocator/building_blocks/bucketizer.d
include/d/std/experimental/allocator/building_blocks/fallback_allocator.d
@@ -539,6 +557,7 @@ include/d/std/regex/internal/ir.d
include/d/std/regex/internal/kickstart.d
include/d/std/regex/internal/parser.d
include/d/std/regex/internal/tests.d
+include/d/std/regex/internal/tests2.d
include/d/std/regex/internal/thompson.d
include/d/std/regex/package.d
include/d/std/signals.d
@@ -556,31 +575,25 @@ include/d/std/utf.d
include/d/std/uuid.d
include/d/std/variant.d
include/d/std/windows/charset.d
-include/d/std/windows/iunknown.d
include/d/std/windows/registry.d
include/d/std/windows/syserror.d
include/d/std/xml.d
include/d/std/zip.d
include/d/std/zlib.d
lib/libdruntime-ldc-debug-shared.so
-lib/libdruntime-ldc-debug-shared.so.2.0.77
-lib/libdruntime-ldc-debug-shared.so.77
+lib/libdruntime-ldc-debug-shared.so.2.0.79
+lib/libdruntime-ldc-debug-shared.so.79
lib/libdruntime-ldc-debug.a
lib/libdruntime-ldc-shared.so
-lib/libdruntime-ldc-shared.so.2.0.77
-lib/libdruntime-ldc-shared.so.77
+lib/libdruntime-ldc-shared.so.2.0.79
+lib/libdruntime-ldc-shared.so.79
lib/libdruntime-ldc.a
-lib/libldc-jit-rt.a
-lib/libldc-jit.so
-lib/libldc-jit.so.2.0.77
-lib/libldc-jit.so.77
-lib/libldc-profile-rt.a
lib/libphobos2-ldc-debug-shared.so
-lib/libphobos2-ldc-debug-shared.so.2.0.77
-lib/libphobos2-ldc-debug-shared.so.77
+lib/libphobos2-ldc-debug-shared.so.2.0.79
+lib/libphobos2-ldc-debug-shared.so.79
lib/libphobos2-ldc-debug.a
lib/libphobos2-ldc-shared.so
-lib/libphobos2-ldc-shared.so.2.0.77
-lib/libphobos2-ldc-shared.so.77
+lib/libphobos2-ldc-shared.so.2.0.79
+lib/libphobos2-ldc-shared.so.79
lib/libphobos2-ldc.a
@dir include/d/etc/c/zlib