aboutsummaryrefslogtreecommitdiffstats
path: root/lang/mono/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-01-02 03:16:15 +0800
committermarcus <marcus@FreeBSD.org>2003-01-02 03:16:15 +0800
commitbd3ac016874b53475c262446f25572627ae8eba7 (patch)
tree0a40285e6c8962ad6380b27d0e3c725e733d4c47 /lang/mono/Makefile
parentcd255c486fb77b05b75054ee0395f35ca83515fa (diff)
downloadfreebsd-ports-gnome-bd3ac016874b53475c262446f25572627ae8eba7.tar.gz
freebsd-ports-gnome-bd3ac016874b53475c262446f25572627ae8eba7.tar.zst
freebsd-ports-gnome-bd3ac016874b53475c262446f25572627ae8eba7.zip
Update to 0.17.
Requested by: many Not tested by: me
Diffstat (limited to 'lang/mono/Makefile')
-rw-r--r--lang/mono/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 0e6bb6627774..7af8c13a9dd0 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mono
-PORTVERSION= 0.13
-PORTREVISION= 1
+PORTVERSION= 0.17
CATEGORIES= lang
MASTER_SITES= http://www.go-mono.com/archive/
@@ -18,21 +17,21 @@ LIB_DEPENDS= glib-2.0.0:${PORTSDIR}/devel/glib20 \
gc.1:${PORTSDIR}/devel/boehm-gc
USE_LIBTOOL= yes
-USE_AUTOCONF= yes
USE_REINPLACE= yes
USE_BISON= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack
CONFIGURE_ARGS= --program-transform-name=\'\'
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-MAN1= mcs.1 mint.1 mono.1 monoburg.1 monodis.1 monostyle.1
+MAN1= mcs.1 mint.1 mono.1 monoburg.1 monodis.1 monostyle.1 \
+ sqlsharpcli.1
MAN5= mono-config.5
-pre-patch:
- @find ${WRKSRC} -name Makefile.in | xargs ${REINPLACE_CMD} -e \
- 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
- @find ${WRKSRC}/mono -name *.c | xargs ${REINPLACE_CMD} -e \
- 's|gc/gc.h|'${LOCALBASE}/'include/gc.h|g'
+post-patch:
+ @${REINPLACE_CMD} -e 's|<gc.h|<'${LOCALBASE}/'include/gc.h|g' \
+ ${WRKSRC}/mono/os/gc_wrapper.h
.include <bsd.port.mk>