aboutsummaryrefslogtreecommitdiffstats
path: root/lang/nickle/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2012-03-25 19:28:46 +0800
committerdanfe <danfe@FreeBSD.org>2012-03-25 19:28:46 +0800
commitd7c2db261cab5ad364a81ecbeaaa90b15e35585c (patch)
tree4553626dfe2e06cf538939e3bd4022f46fd637fe /lang/nickle/Makefile
parent713d6f045907b8eb0d9543a4e32d8cc1bf0b4ba6 (diff)
downloadfreebsd-ports-gnome-d7c2db261cab5ad364a81ecbeaaa90b15e35585c.tar.gz
freebsd-ports-gnome-d7c2db261cab5ad364a81ecbeaaa90b15e35585c.tar.zst
freebsd-ports-gnome-d7c2db261cab5ad364a81ecbeaaa90b15e35585c.zip
- Provide a comment about what we are reinplacing here for
- Fix a typo (NIPORTEXAMPLES -> NOPORTEXAMPLES) - Merge two options of cpio(1) so that line does not touch screen boundary Feature safe: yes
Diffstat (limited to 'lang/nickle/Makefile')
-rw-r--r--lang/nickle/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/lang/nickle/Makefile b/lang/nickle/Makefile
index 58e7fded24e3..72befef327f7 100644
--- a/lang/nickle/Makefile
+++ b/lang/nickle/Makefile
@@ -26,16 +26,18 @@ LDFLAGS+= ${PTHREAD_LIBS}
MAN1= nickle.1
post-patch:
- @${REINPLACE_CMD} -e \
- '/^SUBDIRS/s|examples|| ; \
- s| -O2||' ${WRKSRC}/Makefile.in
+# Do not descend into "examples" subdirectory to prevent them being installed
+# under DATADIR (instead, we manually install them later in post-install into
+# EXAMPLESDIR; also remove extra -O2 since we provide our own CFLAGS.
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|examples|| ; s| -O2||' \
+ ${WRKSRC}/Makefile.in
post-install:
-.if !defined(NIPORTEXAMPLES)
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
@(cd ${WRKSRC}/examples && ${FIND} . ! \( -name "*Makefile*" -or \
- -name "*.sgml" \) | ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} \
- ${EXAMPLESDIR})
+ -name "*.sgml" \) | ${CPIO} -pdm -LR ${SHAREOWN}:${SHAREGRP} \
+ ${EXAMPLESDIR})
@${FIND} ${EXAMPLESDIR} -type d | ${XARGS} ${CHMOD} a+rx
@${FIND} ${EXAMPLESDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif