aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ocaml
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-10-02 14:40:02 +0800
committerantoine <antoine@FreeBSD.org>2015-10-02 14:40:02 +0800
commit459db6546389b3ef62a9e327f8c333f32cec1dad (patch)
tree6bfa3a50e0c6692f5859592595d8a8f3f630d4e1 /lang/ocaml
parente607cc9696724947fbe6522788fa48cdeed8cf1a (diff)
downloadfreebsd-ports-gnome-459db6546389b3ef62a9e327f8c333f32cec1dad.tar.gz
freebsd-ports-gnome-459db6546389b3ef62a9e327f8c333f32cec1dad.tar.zst
freebsd-ports-gnome-459db6546389b3ef62a9e327f8c333f32cec1dad.zip
Backout r398381, it fails to package
With hat: portmgr MFH: 2015Q4
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile2
-rw-r--r--lang/ocaml/distinfo4
-rw-r--r--lang/ocaml/files/patch-configure98
3 files changed, 79 insertions, 25 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index b19047e6386d..33dbd8b53bec 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -3,7 +3,7 @@
# for committer: bump PORTREVISION for math/facile whenever ocaml gets updated
PORTNAME= ocaml
-PORTVERSION= 4.02.3
+PORTVERSION= 4.02.1
CATEGORIES= lang
MASTER_SITES= http://caml.inria.fr/pub/distrib/${DISTNAME:R}/ GENTOO \
http://caml.inria.fr/pub/distrib/${DISTNAME:R}/:docs
diff --git a/lang/ocaml/distinfo b/lang/ocaml/distinfo
index 7d6268c276f7..727bb4b43fd7 100644
--- a/lang/ocaml/distinfo
+++ b/lang/ocaml/distinfo
@@ -1,5 +1,5 @@
-SHA256 (ocaml-4.02.3.tar.xz) = 83c6697e135b599a196fd7936eaf8a53dd6b8f3155a796d18407b56f91df9ce3
-SIZE (ocaml-4.02.3.tar.xz) = 2058552
+SHA256 (ocaml-4.02.1.tar.xz) = 68c4b01be54c23bc20fc0a8beaa5c7433b8483f8950490129cfe7662e0c6f4dc
+SIZE (ocaml-4.02.1.tar.xz) = 2031244
SHA256 (ocaml-4.02-refman-html.tar.gz) = 1d3b7e5494c075d86c760f6320acba086d686e7409cb75f8267bccfb6ad5f3a8
SIZE (ocaml-4.02-refman-html.tar.gz) = 612839
SHA256 (ocaml-4.02-refman.ps.gz) = b14b5aec1e4e1aded2d36e78ceeedfc3c19c3369b257ab507f6a0755651e8f4a
diff --git a/lang/ocaml/files/patch-configure b/lang/ocaml/files/patch-configure
index 2c3258e7d4c8..c9f609782352 100644
--- a/lang/ocaml/files/patch-configure
+++ b/lang/ocaml/files/patch-configure
@@ -1,25 +1,79 @@
-Remove attempts add the -O compiler option -- this ends up lowering optimization
-level for most people (from -O2 to -O).
-
- -mi
-
---- configure 2015-05-12 14:46:37 UTC
-+++ configure 2015-09-22 22:15:58 UTC
-@@ -447,5 +447,5 @@
- # Configure compiler to use in further tests
+--- configure.orig 2014-10-03 19:25:46 UTC
++++ configure
+@@ -85,10 +85,6 @@ exec 3>&1
--cc="$bytecc -O $bytecclinkopts"
-+cc="$bytecc $bytecclinkopts"
- export cc cclibs verbose
+ # Parse command-line arguments
-@@ -1687,10 +1687,4 @@
- fi
-
--# Add Unix-style optimization flag
--bytecccompopts="-O $bytecccompopts"
--dllcccompopts="-O $dllcccompopts"
--nativecccompopts="-O $nativecccompopts"
--sharedcccompopts="-O $sharedcccompopts"
+-if echo "$configure_options" | grep -q -e '--\?[a-zA-Z0-9-]\+='; then
+- err "Arguments to this script look like '-prefix /foo/bar', not '-prefix=/foo/bar' (note the '=')."
+-fi
-
- # Final twiddling of compiler options to work around known bugs
-
+ while : ; do
+ case "$1" in
+ "") break;;
+@@ -659,7 +659,8 @@ if test $with_sharedlibs = "yes"; then
+ mksharedlib="$flexlink"
+ mkmaindll="$flexlink -maindll"
+ shared_libraries_supported=true;;
+- *-*-linux-gnu|*-*-linux|*-*-freebsd[3-9]*|*-*-freebsd[1-9][0-9]*|*-*-openbsd*|*-*-netbsd*|*-*-gnu*|*-*-haiku*)
++ *-*-linux-gnu|*-*-linux|*-*-freebsd[3-9]*|*-*-freebsd[1-9][0-9]*| \
++ *-*-dragonfly*|*-*-openbsd*|*-*-netbsd*|*-*-gnu*|*-*-haiku*)
+ sharedcccompopts="-fPIC"
+ mksharedlib="$bytecc -shared"
+ bytecclinkopts="$bytecclinkopts -Wl,-E"
+@@ -761,11 +758,13 @@ if test $with_sharedlibs = "yes"; then
+ fi;;
+ x86_64-*-darwin*) natdynlink=true;;
+ powerpc*-*-linux*) natdynlink=true;;
++ powerpc*-*-freebsd*) natdynlink=true;;
+ sparc*-*-linux*) natdynlink=true;;
+ i686-*-kfreebsd*) natdynlink=true;;
+ x86_64-*-kfreebsd*) natdynlink=true;;
+ i[3456]86-*-freebsd*) natdynlink=true;;
+ x86_64-*-freebsd*) natdynlink=true;;
++ x86_64-*-dragonfly*) natdynlink=true;;
+ i[3456]86-*-openbsd*) natdynlink=true;;
+ x86_64-*-openbsd*) natdynlink=true;;
+ i[3456]86-*-netbsd*) natdynlink=true;;
+@@ -815,6 +814,7 @@ case "$target" in
+ i[3456]86-*-gnu*) arch=i386; system=gnu;;
+ i[3456]86-*-mingw*) arch=i386; system=mingw;;
+ powerpc*-*-linux*) arch=power; model=ppc; system=elf;;
++ powerpc-*-freebsd*) arch=power; model=ppc; system=bsd_elf;;
+ powerpc-*-netbsd*) arch=power; model=ppc; system=elf;;
+ powerpc-*-openbsd*) arch=power; model=ppc; system=bsd_elf;;
+ powerpc-*-rhapsody*) arch=power; model=ppc; system=rhapsody;;
+@@ -833,6 +833,7 @@ case "$target" in
+ zaurus*-*-openbsd*) arch=arm; system=bsd;;
+ x86_64-*-linux*) arch=amd64; system=linux;;
+ x86_64-*-gnu*) arch=amd64; system=gnu;;
++ x86_64-*-dragonfly*) arch=amd64; system=dragonfly;;
+ x86_64-*-freebsd*) arch=amd64; system=freebsd;;
+ x86_64-*-netbsd*) arch=amd64; system=netbsd;;
+ x86_64-*-openbsd*) arch=amd64; system=openbsd;;
+@@ -905,6 +908,8 @@ case "$arch,$system" in
+ aspp="${TOOLPREF}cc -c";;
+ *,freebsd) as="${TOOLPREF}as"
+ aspp="${TOOLPREF}cc -c";;
++ *,dragonfly) as="as"
++ aspp="cc -c";;
+ amd64,*|arm,*|arm64,*|i386,*|power,bsd*|sparc,*)
+ as="${TOOLPREF}as"
+ aspp="${TOOLPREF}gcc -c";;
+@@ -1390,7 +1395,7 @@ if test "$pthread_wanted" = "yes"; then
+ bytecccompopts="$bytecccompopts -D_REENTRANT"
+ nativecccompopts="$nativecccompopts -D_REENTRANT"
+ case "$target" in
+- *-*-freebsd*)
++ *-*-freebsd*|*-*-dragonfly*)
+ bytecccompopts="$bytecccompopts -D_THREAD_SAFE"
+ nativecccompopts="$nativecccompopts -D_THREAD_SAFE";;
+ *-*-openbsd*)
+@@ -1560,6 +1565,7 @@ if test "$x11_include" = "not found"; th
+ else
+ x11_libs="-L$dir"
+ case "$target" in
++ *-*-freebsd*|*-*-dragonfly*) x11_link="-L$dir -lX11";;
+ *-kfreebsd*-gnu) x11_link="-L$dir -lX11";;
+ *-*-*bsd*) x11_link="-R$dir -L$dir -lX11";;
+ *) x11_link="-L$dir -lX11";;