aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ocaml
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2015-10-02 03:24:12 +0800
committermi <mi@FreeBSD.org>2015-10-02 03:24:12 +0800
commit4b01a77bc2c05d6b30706b3f8d177475eaa4382c (patch)
treed8df5f2734c11d392a24977be5e3028d36240c6e /lang/ocaml
parent49da418b3db2c6ce00460e3a2e402d7328cf537f (diff)
downloadfreebsd-ports-gnome-4b01a77bc2c05d6b30706b3f8d177475eaa4382c.tar.gz
freebsd-ports-gnome-4b01a77bc2c05d6b30706b3f8d177475eaa4382c.tar.zst
freebsd-ports-gnome-4b01a77bc2c05d6b30706b3f8d177475eaa4382c.zip
Upgrade from 4.02.1 to 4.02.3. Disable adding of explicit -O to compiler flags,
because that ends up lowering optimization for most people (from -O2). Approved by: maintainer (The upgrade is too minor to justify revision bumping of depending ports.)
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile2
-rw-r--r--lang/ocaml/distinfo4
-rw-r--r--lang/ocaml/files/patch-configure98
3 files changed, 25 insertions, 79 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 33dbd8b53bec..b19047e6386d 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -3,7 +3,7 @@
# for committer: bump PORTREVISION for math/facile whenever ocaml gets updated
PORTNAME= ocaml
-PORTVERSION= 4.02.1
+PORTVERSION= 4.02.3
CATEGORIES= lang
MASTER_SITES= http://caml.inria.fr/pub/distrib/${DISTNAME:R}/ GENTOO \
http://caml.inria.fr/pub/distrib/${DISTNAME:R}/:docs
diff --git a/lang/ocaml/distinfo b/lang/ocaml/distinfo
index 727bb4b43fd7..7d6268c276f7 100644
--- a/lang/ocaml/distinfo
+++ b/lang/ocaml/distinfo
@@ -1,5 +1,5 @@
-SHA256 (ocaml-4.02.1.tar.xz) = 68c4b01be54c23bc20fc0a8beaa5c7433b8483f8950490129cfe7662e0c6f4dc
-SIZE (ocaml-4.02.1.tar.xz) = 2031244
+SHA256 (ocaml-4.02.3.tar.xz) = 83c6697e135b599a196fd7936eaf8a53dd6b8f3155a796d18407b56f91df9ce3
+SIZE (ocaml-4.02.3.tar.xz) = 2058552
SHA256 (ocaml-4.02-refman-html.tar.gz) = 1d3b7e5494c075d86c760f6320acba086d686e7409cb75f8267bccfb6ad5f3a8
SIZE (ocaml-4.02-refman-html.tar.gz) = 612839
SHA256 (ocaml-4.02-refman.ps.gz) = b14b5aec1e4e1aded2d36e78ceeedfc3c19c3369b257ab507f6a0755651e8f4a
diff --git a/lang/ocaml/files/patch-configure b/lang/ocaml/files/patch-configure
index c9f609782352..2c3258e7d4c8 100644
--- a/lang/ocaml/files/patch-configure
+++ b/lang/ocaml/files/patch-configure
@@ -1,79 +1,25 @@
---- configure.orig 2014-10-03 19:25:46 UTC
-+++ configure
-@@ -85,10 +85,6 @@ exec 3>&1
+Remove attempts add the -O compiler option -- this ends up lowering optimization
+level for most people (from -O2 to -O).
+
+ -mi
+
+--- configure 2015-05-12 14:46:37 UTC
++++ configure 2015-09-22 22:15:58 UTC
+@@ -447,5 +447,5 @@
+ # Configure compiler to use in further tests
- # Parse command-line arguments
+-cc="$bytecc -O $bytecclinkopts"
++cc="$bytecc $bytecclinkopts"
+ export cc cclibs verbose
--if echo "$configure_options" | grep -q -e '--\?[a-zA-Z0-9-]\+='; then
-- err "Arguments to this script look like '-prefix /foo/bar', not '-prefix=/foo/bar' (note the '=')."
--fi
+@@ -1687,10 +1687,4 @@
+ fi
+
+-# Add Unix-style optimization flag
+-bytecccompopts="-O $bytecccompopts"
+-dllcccompopts="-O $dllcccompopts"
+-nativecccompopts="-O $nativecccompopts"
+-sharedcccompopts="-O $sharedcccompopts"
-
- while : ; do
- case "$1" in
- "") break;;
-@@ -659,7 +659,8 @@ if test $with_sharedlibs = "yes"; then
- mksharedlib="$flexlink"
- mkmaindll="$flexlink -maindll"
- shared_libraries_supported=true;;
-- *-*-linux-gnu|*-*-linux|*-*-freebsd[3-9]*|*-*-freebsd[1-9][0-9]*|*-*-openbsd*|*-*-netbsd*|*-*-gnu*|*-*-haiku*)
-+ *-*-linux-gnu|*-*-linux|*-*-freebsd[3-9]*|*-*-freebsd[1-9][0-9]*| \
-+ *-*-dragonfly*|*-*-openbsd*|*-*-netbsd*|*-*-gnu*|*-*-haiku*)
- sharedcccompopts="-fPIC"
- mksharedlib="$bytecc -shared"
- bytecclinkopts="$bytecclinkopts -Wl,-E"
-@@ -761,11 +758,13 @@ if test $with_sharedlibs = "yes"; then
- fi;;
- x86_64-*-darwin*) natdynlink=true;;
- powerpc*-*-linux*) natdynlink=true;;
-+ powerpc*-*-freebsd*) natdynlink=true;;
- sparc*-*-linux*) natdynlink=true;;
- i686-*-kfreebsd*) natdynlink=true;;
- x86_64-*-kfreebsd*) natdynlink=true;;
- i[3456]86-*-freebsd*) natdynlink=true;;
- x86_64-*-freebsd*) natdynlink=true;;
-+ x86_64-*-dragonfly*) natdynlink=true;;
- i[3456]86-*-openbsd*) natdynlink=true;;
- x86_64-*-openbsd*) natdynlink=true;;
- i[3456]86-*-netbsd*) natdynlink=true;;
-@@ -815,6 +814,7 @@ case "$target" in
- i[3456]86-*-gnu*) arch=i386; system=gnu;;
- i[3456]86-*-mingw*) arch=i386; system=mingw;;
- powerpc*-*-linux*) arch=power; model=ppc; system=elf;;
-+ powerpc-*-freebsd*) arch=power; model=ppc; system=bsd_elf;;
- powerpc-*-netbsd*) arch=power; model=ppc; system=elf;;
- powerpc-*-openbsd*) arch=power; model=ppc; system=bsd_elf;;
- powerpc-*-rhapsody*) arch=power; model=ppc; system=rhapsody;;
-@@ -833,6 +833,7 @@ case "$target" in
- zaurus*-*-openbsd*) arch=arm; system=bsd;;
- x86_64-*-linux*) arch=amd64; system=linux;;
- x86_64-*-gnu*) arch=amd64; system=gnu;;
-+ x86_64-*-dragonfly*) arch=amd64; system=dragonfly;;
- x86_64-*-freebsd*) arch=amd64; system=freebsd;;
- x86_64-*-netbsd*) arch=amd64; system=netbsd;;
- x86_64-*-openbsd*) arch=amd64; system=openbsd;;
-@@ -905,6 +908,8 @@ case "$arch,$system" in
- aspp="${TOOLPREF}cc -c";;
- *,freebsd) as="${TOOLPREF}as"
- aspp="${TOOLPREF}cc -c";;
-+ *,dragonfly) as="as"
-+ aspp="cc -c";;
- amd64,*|arm,*|arm64,*|i386,*|power,bsd*|sparc,*)
- as="${TOOLPREF}as"
- aspp="${TOOLPREF}gcc -c";;
-@@ -1390,7 +1395,7 @@ if test "$pthread_wanted" = "yes"; then
- bytecccompopts="$bytecccompopts -D_REENTRANT"
- nativecccompopts="$nativecccompopts -D_REENTRANT"
- case "$target" in
-- *-*-freebsd*)
-+ *-*-freebsd*|*-*-dragonfly*)
- bytecccompopts="$bytecccompopts -D_THREAD_SAFE"
- nativecccompopts="$nativecccompopts -D_THREAD_SAFE";;
- *-*-openbsd*)
-@@ -1560,6 +1565,7 @@ if test "$x11_include" = "not found"; th
- else
- x11_libs="-L$dir"
- case "$target" in
-+ *-*-freebsd*|*-*-dragonfly*) x11_link="-L$dir -lX11";;
- *-kfreebsd*-gnu) x11_link="-L$dir -lX11";;
- *-*-*bsd*) x11_link="-R$dir -L$dir -lX11";;
- *) x11_link="-L$dir -lX11";;
+ # Final twiddling of compiler options to work around known bugs
+