aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ocaml
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2014-08-02 19:57:17 +0800
committerdanfe <danfe@FreeBSD.org>2014-08-02 19:57:17 +0800
commit7dec6683e738aa225afc6a8d0b4de864143e6baa (patch)
tree4976c718765a1ada42af6031313be0bc63d6a5c9 /lang/ocaml
parentb0d8f747e3d8cb884fe90c6c5374d9de51cf0086 (diff)
downloadfreebsd-ports-gnome-7dec6683e738aa225afc6a8d0b4de864143e6baa.tar.gz
freebsd-ports-gnome-7dec6683e738aa225afc6a8d0b4de864143e6baa.tar.zst
freebsd-ports-gnome-7dec6683e738aa225afc6a8d0b4de864143e6baa.zip
Unbreak the build and packaging on PowerPC.
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile3
-rw-r--r--lang/ocaml/files/patch-configure39
2 files changed, 20 insertions, 22 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index f9a3aec75c0f..91706bb5b89b 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -126,9 +126,6 @@ BROKEN= ocamlc.opt seg-faults on ${ARCH}, please try to fix
.endif
post-extract:
-.if ${OCAML_ARCH} == power
- ${MV} ${WRKSRC}/asmrun/power-elf.S ${WRKSRC}/asmrun/power-bsd.S
-.endif
.if ${PORT_OPTIONS:MDOCS}
@if ! (cd ${WRKDIR} && \
${TAR} xf ${_DISTDIR}${DOCSDISTNAME}-refman-html.tar.gz \
diff --git a/lang/ocaml/files/patch-configure b/lang/ocaml/files/patch-configure
index 8558c83a1d8b..3b5d6cd92fba 100644
--- a/lang/ocaml/files/patch-configure
+++ b/lang/ocaml/files/patch-configure
@@ -1,6 +1,6 @@
--- configure.orig 2014-05-08 09:28:26.000000000 +0200
+++ configure 2014-05-08 09:31:54.000000000 +0200
-@@ -545,9 +545,10 @@
+@@ -545,9 +545,10 @@ if test $withsharedlibs = "yes"; then
mksharedlib="$flexlink"
mkmaindll="$flexlink -maindll"
shared_libraries_supported=true;;
@@ -13,7 +13,7 @@
bytecclinkopts="$bytecclinkopts -Wl,-E"
byteccrpath="-Wl,-rpath,"
mksharedlibrpath="-Wl,-rpath,"
-@@ -557,7 +558,7 @@
+@@ -557,7 +558,7 @@ if test $withsharedlibs = "yes"; then
case "$bytecc" in
gcc*)
sharedcccompopts="-fPIC"
@@ -22,7 +22,7 @@
byteccrpath="-Wl,-rpath,"
mksharedlibrpath="-Wl,-rpath,"
shared_libraries_supported=true;;
-@@ -573,11 +574,11 @@
+@@ -573,11 +574,11 @@ if test $withsharedlibs = "yes"; then
gcc*)
sharedcccompopts="-fPIC"
if sh ./solaris-ld; then
@@ -36,7 +36,7 @@
bytecclinkopts="$bytecclinkopts -Wl,-E"
natdynlinkopts="-Wl,-E"
byteccrpath="-Wl,-rpath,"
-@@ -601,12 +602,12 @@
+@@ -601,12 +602,12 @@ if test $withsharedlibs = "yes"; then
mksharedlibrpath="-rpath "
shared_libraries_supported=true;;
i[3456]86-*-darwin[89].*)
@@ -51,7 +51,7 @@
bytecccompopts="$dl_defs $bytecccompopts"
dl_needs_underscore=false
shared_libraries_supported=true;;
-@@ -616,7 +617,7 @@
+@@ -616,7 +617,7 @@ if test $withsharedlibs = "yes"; then
shared_libraries_supported=false;;
*-*-openbsd*)
sharedcccompopts="-fPIC"
@@ -60,7 +60,7 @@
bytecclinkopts="$bytecclinkopts -Wl,-E"
natdynlinkopts="-Wl,-E"
byteccrpath="-Wl,-rpath,"
-@@ -651,12 +652,15 @@
+@@ -651,12 +652,16 @@ if test $withsharedlibs = "yes"; then
x86_64-*-kfreebsd*) natdynlink=true;;
i[345]86-*-freebsd*) natdynlink=true;;
x86_64-*-freebsd*) natdynlink=true;;
@@ -73,10 +73,11 @@
i386-*-gnu0.3) natdynlink=true;;
arm*-*-linux*) natdynlink=true;;
+ arm*-*-freebsd*) natdynlink=true;;
++ powerpc*-*-freebsd*) natdynlink=true;;
esac
fi
-@@ -680,6 +684,7 @@
+@@ -680,6 +685,7 @@ case "$host" in
sparc*-*-gnu*) arch=sparc; system=gnu;;
i[3456]86-*-linux*) arch=i386; system=linux_`sh ./runtest elf.c`;;
i[3456]86-*-*bsd*) arch=i386; system=bsd_`sh ./runtest elf.c`;;
@@ -84,15 +85,15 @@
i[3456]86-*-nextstep*) arch=i386; system=nextstep;;
i[3456]86-*-solaris*) if $arch64; then
arch=amd64; system=solaris
-@@ -695,6 +700,7 @@
+@@ -695,6 +701,7 @@ case "$host" in
fi;;
i[3456]86-*-gnu*) arch=i386; system=gnu;;
powerpc*-*-linux*) arch=power; model=ppc; system=elf;;
-+ powerpc*-*-freebsd*) arch=power; model=ppc; system=elf;;
++ powerpc*-*-freebsd*) arch=power; model=ppc; system=bsd_elf;;
powerpc-*-netbsd*) arch=power; model=ppc; system=elf;;
powerpc-*-openbsd*) arch=power; model=ppc; system=bsd_elf;;
powerpc-*-rhapsody*) arch=power; model=ppc; system=rhapsody;;
-@@ -708,12 +714,14 @@
+@@ -708,12 +715,14 @@ case "$host" in
armv5te*-*-linux-gnueabi) arch=arm; model=armv5te; system=linux_eabi;;
armv5*-*-linux-gnueabi) arch=arm; model=armv5; system=linux_eabi;;
arm*-*-linux-gnueabi) arch=arm; system=linux_eabi;;
@@ -107,7 +108,7 @@
esac
# Some platforms exist both in 32-bit and 64-bit variants, not distinguished
-@@ -734,7 +742,7 @@
+@@ -734,7 +743,7 @@ else
fi
nativecccompopts=''
@@ -116,7 +117,7 @@
# FIXME the naming of nativecclinkopts is broken: these are options for
# ld (for shared libs), not for cc
nativeccrpath="$byteccrpath"
-@@ -766,6 +774,8 @@
+@@ -766,6 +775,8 @@ case "$arch,$model,$system" in
aspp='gcc -m64 -c';;
amd64,*,*) as='as'
aspp='gcc -c';;
@@ -125,7 +126,7 @@
arm,*,*) as='as';
aspp='gcc -c';;
i386,*,solaris) as='as'
-@@ -803,6 +813,8 @@
+@@ -803,6 +814,8 @@ case "$arch,$model,$system" in
amd64,*,linux) profiling='prof';;
amd64,*,gnu) profiling='prof';;
arm,*,linux*) profiling='prof';;
@@ -134,7 +135,7 @@
*) profiling='noprof';;
esac
-@@ -1204,7 +1216,7 @@
+@@ -1204,7 +1217,7 @@ if test "$pthread_wanted" = "yes"; then
case "$host" in
*-*-solaris*) pthread_link="-lpthread -lposix4"
pthread_caml_link="-cclib -lpthread -cclib -lposix4";;
@@ -143,7 +144,7 @@
pthread_caml_link="-cclib -pthread";;
*-*-openbsd*) pthread_link="-pthread"
pthread_caml_link="-cclib -pthread";;
-@@ -1218,7 +1230,7 @@
+@@ -1218,7 +1231,7 @@ if test "$pthread_wanted" = "yes"; then
bytecccompopts="$bytecccompopts -D_REENTRANT"
nativecccompopts="$nativecccompopts -D_REENTRANT"
case "$host" in
@@ -152,7 +153,7 @@
bytecccompopts="$bytecccompopts -D_THREAD_SAFE"
nativecccompopts="$nativecccompopts -D_THREAD_SAFE";;
*-*-openbsd*)
-@@ -1388,7 +1400,6 @@
+@@ -1388,7 +1401,6 @@ if test "$x11_include" = "not found"; th
x11_libs="-L$dir"
case "$host" in
*-kfreebsd*-gnu) x11_link="-L$dir -lX11";;
@@ -160,7 +161,7 @@
*) x11_link="-L$dir -lX11";;
esac
fi
-@@ -1514,7 +1525,7 @@
+@@ -1514,7 +1526,7 @@ if test $has_tk = true; then
Tcl_DoOneEvent
then
case "$host" in
@@ -169,7 +170,7 @@
*) tk_libs="-L/usr/pkg/lib $tk_libs $tk_x11_libs -ltk$tkmaj$tkmin -ltcl$tclmaj$tclmin -lpthread $tkauxlibs";;
esac
else
-@@ -1528,14 +1539,14 @@
+@@ -1528,14 +1540,14 @@ if test $has_tk = true; then
echo "Tcl/Tk libraries found."
elif sh ./hasgot -L/sw/lib $tk_libs $tk_x11_libs $tkauxlibs Tk_SetGrid; then
case "$host" in
@@ -186,7 +187,7 @@
*) tk_libs="-L/usr/pkg/lib $tk_libs";;
esac
echo "Tcl/Tk libraries found."
-@@ -1564,10 +1575,10 @@
+@@ -1564,10 +1576,10 @@ fi
# Look for BFD library
if ./hasgot -i bfd.h && \