aboutsummaryrefslogtreecommitdiffstats
path: root/lang/oorexx
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2007-11-14 12:57:15 +0800
committerfjoe <fjoe@FreeBSD.org>2007-11-14 12:57:15 +0800
commit4b3a9247e8128da2837ab8b92081e5a68aab2899 (patch)
tree6d5f7c02d69de3320a5a76dd2556ec5b5630b6d8 /lang/oorexx
parentc4c3d7fcb0d1ad0cb69b0f739f6a60b05f69fcad (diff)
downloadfreebsd-ports-gnome-4b3a9247e8128da2837ab8b92081e5a68aab2899.tar.gz
freebsd-ports-gnome-4b3a9247e8128da2837ab8b92081e5a68aab2899.tar.zst
freebsd-ports-gnome-4b3a9247e8128da2837ab8b92081e5a68aab2899.zip
Fix build on FreeBSD 7 and later.
Approved by: portmgr (pav)
Diffstat (limited to 'lang/oorexx')
-rw-r--r--lang/oorexx/Makefile4
-rw-r--r--lang/oorexx/files/patch-rexxapi-RexxAPIManager.cpp12
2 files changed, 12 insertions, 4 deletions
diff --git a/lang/oorexx/Makefile b/lang/oorexx/Makefile
index ff91a81670f6..854f1a7e4987 100644
--- a/lang/oorexx/Makefile
+++ b/lang/oorexx/Makefile
@@ -21,10 +21,6 @@ MAN1= rexx.1 rexxc.1 rxmigrate.1 rxsubcom.1 rxqueue.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.if ${ARCH} != "i386"
BROKEN= Does not compile on !i386
.endif
diff --git a/lang/oorexx/files/patch-rexxapi-RexxAPIManager.cpp b/lang/oorexx/files/patch-rexxapi-RexxAPIManager.cpp
new file mode 100644
index 000000000000..060fb29c5911
--- /dev/null
+++ b/lang/oorexx/files/patch-rexxapi-RexxAPIManager.cpp
@@ -0,0 +1,12 @@
+--- rexxapi/RexxAPIManager.cpp.orig 2007-11-14 03:31:03.000000000 +0600
++++ rexxapi/RexxAPIManager.cpp 2007-11-14 03:32:26.000000000 +0600
+@@ -108,6 +108,9 @@
+ #include <signal.h>
+ #include <limits.h>
+ #endif
++#if defined(__FreeBSD__)
++#include <limits.h>
++#endif
+ /* #if defined(LINUX) && !defined(OPSYS_SUN) */
+ /* #include <bits/posix1_lim.h> */
+ /* #endif */