aboutsummaryrefslogtreecommitdiffstats
path: root/lang/p2c/scripts
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1994-10-20 09:51:56 +0800
committerjkh <jkh@FreeBSD.org>1994-10-20 09:51:56 +0800
commit76383c2b02637b3da123b34f6cb1f9deff4462b4 (patch)
tree38cb85dd0ece22d328d636f73eb28d382d076cb2 /lang/p2c/scripts
parent473a30c50b3c65125ff2beef36e17eb74990dedf (diff)
downloadfreebsd-ports-gnome-76383c2b02637b3da123b34f6cb1f9deff4462b4.tar.gz
freebsd-ports-gnome-76383c2b02637b3da123b34f6cb1f9deff4462b4.tar.zst
freebsd-ports-gnome-76383c2b02637b3da123b34f6cb1f9deff4462b4.zip
Changes from Jean-Marc Zucconi to obey PREFIX properly.
Submitted by: jmz
Diffstat (limited to 'lang/p2c/scripts')
-rw-r--r--lang/p2c/scripts/configure20
1 files changed, 11 insertions, 9 deletions
diff --git a/lang/p2c/scripts/configure b/lang/p2c/scripts/configure
index eab3c4597275..d1784843c707 100644
--- a/lang/p2c/scripts/configure
+++ b/lang/p2c/scripts/configure
@@ -1,19 +1,21 @@
#!/bin/sh
-cat >>${WRKSRC}/Makefile <<END || exit 1;
+cat >>$WRKSRC/Makefile <<END || exit 1;
+
all:
cd src; make OPT=-O
END
-mv ${WRKSRC}/src/p2cc.perl ${WRKSRC}/src/p2cc.perl.orig || exit 1;
-sed -e 1s/--.*// < ${WRKSRC}/src/p2cc.perl.orig > ${WRKSRC}/src/p2cc.perl || exit 1;
+mv $WRKSRC/src/p2cc.perl $WRKSRC/src/p2cc.perl.orig || exit 1;
+sed -e 1s/--.*// < $WRKSRC/src/p2cc.perl.orig > $WRKSRC/src/p2cc.perl || exit 1;
-cat >>${WRKSRC}/src/Makefile <<END || exit 1;
-HOMEDIR=/usr/local/lib/p2c
-INCDIR=/usr/local/include/p2c
-BINDIR=/usr/local/bin
-LIBDIR=/usr/local/lib
-MANDIR=/usr/local/man/man1
+cat >>$WRKSRC/src/Makefile <<END || exit 1;
+HOMEDIR=$PREFIX/lib/p2c
+INCDIR=$PREFIX/include/p2c
+BINDIR=$PREFIX/bin
+LIBDIR=$PREFIX/lib
+MANDIR=$PREFIX/man/man1
+ABSHOMEDIR=$PREFIX/lib/p2c
END
exit 0;