aboutsummaryrefslogtreecommitdiffstats
path: root/lang/parrot/Makefile
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2006-03-15 17:10:47 +0800
committerskv <skv@FreeBSD.org>2006-03-15 17:10:47 +0800
commit0038fcfa22eb31acdcee6e3bd813ecf458d52212 (patch)
treea076703951f93e170f15504a135538d85b25e8cb /lang/parrot/Makefile
parentb06402a517b6945f8b6852a18ab0ca11898627eb (diff)
downloadfreebsd-ports-gnome-0038fcfa22eb31acdcee6e3bd813ecf458d52212.tar.gz
freebsd-ports-gnome-0038fcfa22eb31acdcee6e3bd813ecf458d52212.tar.zst
freebsd-ports-gnome-0038fcfa22eb31acdcee6e3bd813ecf458d52212.zip
Update to 0.4.2
Diffstat (limited to 'lang/parrot/Makefile')
-rw-r--r--lang/parrot/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index ae1a7994a879..e9f88eef1bd9 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= parrot
-PORTVERSION= 0.2.2
+PORTVERSION= 0.4.2
CATEGORIES= lang perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/L/LT/LTOETSCH
@@ -18,33 +18,36 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4 \
icudata.34:${PORTSDIR}/devel/icu
+USE_GCC= 3.4+
USE_PERL5= yes
USE_GMAKE= yes
#USE_SDL= yes
+INSTALLS_SHLIB= yes
+
CONFIGURE_SCRIPT= Configure.pl
-CONFIGURE_ARGS= --cc=${CC} --ld=${LD} --ccflags="${CFLAGS}" \
+CONFIGURE_ARGS= --cc=${CC} --cxx=${CXX} --ld=${CC} --ccflags="${CFLAGS}" \
--ldflags="${LDFLAGS} -L/usr/lib -L${LOCALBASE}/lib" \
--icu-config=${LOCALBASE}/bin/icu-config \
- --optimize --jitcapable --verbose \
- --prefix=${PREFIX}/parrot
+ --optimize --jitcapable --parrot_is_shared \
+ --verbose \
+ --prefix=${PREFIX}
+# --verbose
+
+post-patch:
+ ${PERL} -pi -e "s=libdir}, 'pkgconfig=prefix}, 'libdata/pkgconfig=" \
+ ${WRKSRC}/tools/dev/install_files.pl
do-configure:
cd ${WRKSRC} && ${PERL} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
- @${PERL} -pi -e 's/(?<=nci_test\$$\(O\)) \$$\(C_LIBS\)//' \
- ${WRKSRC}/Makefile
test:
cd ${WRKSRC} && ${MAKE} test
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
-BROKEN= "Build is broken."
-.endif
-
.if ${PERL_LEVEL} < 500800
-IGNORE= Perl 5.8 or newer required. Install lang/perl5.8 and try again.
+IGNORE= perl 5.8 or newer required. Install lang/perl5.8 and try again
.endif
.include <bsd.port.post.mk>