aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pbasic
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-11-25 00:05:13 +0800
committermiwi <miwi@FreeBSD.org>2011-11-25 00:05:13 +0800
commitee2ab10dcc57a9dc45b16922c4867bafb879e1cf (patch)
tree683a2a8883d0c0fe805dd73f4012412338cbc502 /lang/pbasic
parent4d1e1cb3c7c8a6f90630d71a3687f17e407e7c10 (diff)
downloadfreebsd-ports-gnome-ee2ab10dcc57a9dc45b16922c4867bafb879e1cf.tar.gz
freebsd-ports-gnome-ee2ab10dcc57a9dc45b16922c4867bafb879e1cf.tar.zst
freebsd-ports-gnome-ee2ab10dcc57a9dc45b16922c4867bafb879e1cf.zip
- respect CC/CFLAGS
PR: 162539 Submitted by: Jan Beich <jbeich@tormail.net> Approved by: maintainer Feature safe: yes
Diffstat (limited to 'lang/pbasic')
-rw-r--r--lang/pbasic/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/pbasic/Makefile b/lang/pbasic/Makefile
index 9d7cc43b7a51..90c4332608ac 100644
--- a/lang/pbasic/Makefile
+++ b/lang/pbasic/Makefile
@@ -22,6 +22,12 @@ MAKEFILE= makefile
MAN1= pbasic.1
PLIST_FILES= bin/pbasic
+post-patch: .SILENT
+ ${REINPLACE_CMD} -e '/^CC/s/=/?=/' \
+ -e '/^CFLAGS/{s/=/+=/;s/-O//;}' \
+ ${WRKSRC}/freebsd/makefile
+ ${ECHO_CMD} '.PHONY: $$(SYSTEMS)' >>${WRKSRC}/makefile
+
do-configure:
-cd ${WRKSRC} ; ${RM} -rf termio m68000 msdos vax pyramid ns32000 \
pdp11 cursor/cursor.dos cursor/cursor.ukc