aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5-devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-09-12 20:22:18 +0800
committermat <mat@FreeBSD.org>2017-09-12 20:22:18 +0800
commit63993d92fa95be25118a913d52f1a7fc1db816bc (patch)
tree7371c3b6a96bd5360bad5f9075c89c5351b405a9 /lang/perl5-devel
parentb9dd2dc41c85dce0b9757b8387aa76aa108052dc (diff)
downloadfreebsd-ports-gnome-63993d92fa95be25118a913d52f1a7fc1db816bc.tar.gz
freebsd-ports-gnome-63993d92fa95be25118a913d52f1a7fc1db816bc.tar.zst
freebsd-ports-gnome-63993d92fa95be25118a913d52f1a7fc1db816bc.zip
Fix -i -ne usage when the argument has a full path.
Right now, it fails with: Can't rename in-place work file '/tmp/g5jI40tc' to '/tmp/foo': Capabilities insufficient Obtained from: #p5p on irc.perl.org Sponsored by: Absolight
Diffstat (limited to 'lang/perl5-devel')
-rw-r--r--lang/perl5-devel/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/lang/perl5-devel/Makefile b/lang/perl5-devel/Makefile
index fec62e86eb5b..cd73b07058c4 100644
--- a/lang/perl5-devel/Makefile
+++ b/lang/perl5-devel/Makefile
@@ -7,7 +7,7 @@ PORTNAME= perl
DISTVERSIONPREFIX= v
DISTVERSION= ${GH_TAGNAME:C/^v//:C/-g[0-9a-f]*$//}
DISTVERSIONSUFFIX= ${GH_TAGNAME:C/.*-g/-g/}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= lang devel perl5
# XXX Leave only CPAN.
MASTER_SITES= LOCAL/mat/perl GH
@@ -126,6 +126,10 @@ CONFIGURE_ARGS+= \
-Alddlflags='-L${WRKSRC} -L${PREFIX}/${_ARCH_LIB}/CORE -lperl' \
-Dshrpldflags='$$(LDDLFLAGS:N-L${WRKSRC}:N-L${PREFIX}/${_ARCH_LIB}/CORE:N-lperl) -Wl,-soname,$$(LIBPERL)'
+# XXX should be fixed soon.
+CONFIGURE_ARGS+= \
+ -Accflags=-DNO_USE_ATFUNCTIONS
+
# Give a hint of where libperl.so can be found.
USE_LDCONFIG= ${PREFIX}/${_ARCH_LIB}/CORE