aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.12
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-08 09:12:10 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-08 09:12:10 +0800
commit9ccc7e92dea72d32d4ae04470bbce43e6f9227da (patch)
tree20264757b2346c435477e3f6cfdf324086bbafe9 /lang/perl5.12
parent07d9e093a64a0c7f96ed0775d50e0f818d98fd80 (diff)
downloadfreebsd-ports-gnome-9ccc7e92dea72d32d4ae04470bbce43e6f9227da.tar.gz
freebsd-ports-gnome-9ccc7e92dea72d32d4ae04470bbce43e6f9227da.tar.zst
freebsd-ports-gnome-9ccc7e92dea72d32d4ae04470bbce43e6f9227da.zip
Welcome bsd.perl.mk. Add support for constructs such as USE_PERL5=5.8.0+.
Drop support for antique perl. Work done by: gabor Sponsored by: Google Summer of Code 2007 Hat: portmgr
Diffstat (limited to 'lang/perl5.12')
-rw-r--r--lang/perl5.12/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index 725f1b4d0b44..4ec9934273c7 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -26,6 +26,8 @@ COMMENT= Practical Extraction and Report Language
PERL_VER= 5.8.8
PERL_ARCH= mach
PERL_VERSION= ${PERL_VER}
+SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
+SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
USE_BZIP2= yes
HAS_CONFIGURE= yes
@@ -51,6 +53,11 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
.include "Makefile.man"
.include <bsd.port.pre.mk>
+PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ SITE_PERL=${SITE_PERL:S|^${LOCALBASE}/||}
+
.if defined(WITH_DEBUGGING)
CONFIGURE_ARGS+= -Doptimize="-g" -DDEBUGGING
STRIP=