aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.16/files
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-02-12 21:46:07 +0800
committermat <mat@FreeBSD.org>2014-02-12 21:46:07 +0800
commita2eb98aa5904e7a4abfd8a168c45bbf3141bac4f (patch)
treea9184b826f6d2e4d0e69c0d40cadfaf2a149d724 /lang/perl5.16/files
parenta30be86c016b08429174653c49ec4bfc94d252cc (diff)
downloadfreebsd-ports-gnome-a2eb98aa5904e7a4abfd8a168c45bbf3141bac4f.tar.gz
freebsd-ports-gnome-a2eb98aa5904e7a4abfd8a168c45bbf3141bac4f.tar.zst
freebsd-ports-gnome-a2eb98aa5904e7a4abfd8a168c45bbf3141bac4f.zip
Massive cleanup of the Perl ports:
- Use SUB_FILES instead of own backed version - Have etc/perl5_version in the package instead of generating a static one at install - Move some mkdirs from pkg-install to pkg-plist - Move the bin/perl5 creation from plist to post-install Reviewed by: az Sponsored by: Absolight
Diffstat (limited to 'lang/perl5.16/files')
-rw-r--r--lang/perl5.16/files/perl-man.conf.in (renamed from lang/perl5.16/files/perl-man.conf)0
-rw-r--r--lang/perl5.16/files/perl5_version.in2
-rw-r--r--lang/perl5.16/files/use.perl.in (renamed from lang/perl5.16/files/use.perl)27
3 files changed, 2 insertions, 27 deletions
diff --git a/lang/perl5.16/files/perl-man.conf b/lang/perl5.16/files/perl-man.conf.in
index 7f265b64652b..7f265b64652b 100644
--- a/lang/perl5.16/files/perl-man.conf
+++ b/lang/perl5.16/files/perl-man.conf.in
diff --git a/lang/perl5.16/files/perl5_version.in b/lang/perl5.16/files/perl5_version.in
new file mode 100644
index 000000000000..97e1f75dfb9f
--- /dev/null
+++ b/lang/perl5.16/files/perl5_version.in
@@ -0,0 +1,2 @@
+# Do not modify PERL_VERSION here, instead use DEFAULT_VERSIONS= perl5=%%PERL_VER%%
+PERL_VERSION=%%PERL_VERSION%%
diff --git a/lang/perl5.16/files/use.perl b/lang/perl5.16/files/use.perl.in
index 3f1f15724d8f..e74d73e063e1 100644
--- a/lang/perl5.16/files/use.perl
+++ b/lang/perl5.16/files/use.perl.in
@@ -4,10 +4,8 @@
LINK_USRBIN="%%LINK_USRBIN%%"
: ${OSVERSION:=`/sbin/sysctl -n kern.osreldate`};
-PERL_ARCH="%%PERL_ARCH%%"
PERL_VERSION="%%PERL_VERSION%%"
PERL_VER="%%PERL_VER%%"
-PERL5_SIGNATURE="%%PERL5_SIGNATURE%%"
banner="# added by use.perl $(/bin/date +'%F %T')"
special_link_list="perl perl5"
@@ -44,20 +42,6 @@ do_create_links()
done
}
-do_post_install()
-{
- INCLUDEDIR=/usr/include
- install -d ${PKG_PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/auto
- install -d ${PKG_PREFIX}/lib/perl5/site_perl/${PERL_VER}/auto
- install -d ${PKG_PREFIX}/lib/perl5/${PERL_VER}/man/man3
- cd ${INCLUDEDIR} && ${PKG_PREFIX}/bin/h2ph *.h machine/*.h sys/*.h >/dev/null
-}
-
-do_remove_perl5_signature()
-{
- [ -f "${PERL5_SIGNATURE}" ] && /bin/rm "${PERL5_SIGNATURE}"
-}
-
do_cleanup_manpath()
{
if [ -f /etc/manpath.config ] ; then
@@ -73,13 +57,6 @@ do_cleanup_manpath()
fi
}
-do_create_perl5_signature()
-{
- echo "${banner}" >>"${PERL5_SIGNATURE}"
- echo "# Do not modify PERL_VERSION here, instead use DEFAULT_VERSIONS= perl5=${PERL_VER}" >>"${PERL5_SIGNATURE}"
- echo "PERL_VERSION=${PERL_VERSION}" >>"${PERL5_SIGNATURE}"
-}
-
do_spam_manpath()
{
if [ -f /etc/manpath.config ] ; then
@@ -91,9 +68,6 @@ do_spam_manpath()
if [ "$2" = "POST-INSTALL" ] ; then
- do_remove_perl5_signature
- do_create_perl5_signature
- do_post_install
if [ ${LINK_USRBIN} = yes ] ; then
do_remove_links
do_create_links
@@ -103,7 +77,6 @@ if [ "$2" = "POST-INSTALL" ] ; then
do_spam_manpath
fi
elif [ "$2" = "POST-DEINSTALL" ] ; then
- do_remove_perl5_signature
[ ${LINK_USRBIN} = yes ] && do_remove_links
[ "${OSVERSION}" -lt 900022 ] && do_cleanup_manpath
fi