aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.16
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-02-15 10:03:29 +0800
committerswills <swills@FreeBSD.org>2012-02-15 10:03:29 +0800
commit004004961e21ddf22f61b3cb63f545b7ccfa5da6 (patch)
treeae571cfef2d8931fa33617df3175a821faf517ae /lang/perl5.16
parent94f25d1e67e15b18920725b061d2e1317ff6f9db (diff)
downloadfreebsd-ports-gnome-004004961e21ddf22f61b3cb63f545b7ccfa5da6.tar.gz
freebsd-ports-gnome-004004961e21ddf22f61b3cb63f545b7ccfa5da6.tar.zst
freebsd-ports-gnome-004004961e21ddf22f61b3cb63f545b7ccfa5da6.zip
- Add option to build with -pthread, default to on. Note this is not the same
as threaded perl. PR: ports/163878 Submitted by: swills (myself) Approved by: portmgr (erwin) Discussed with: tobez With hat: perl@
Diffstat (limited to 'lang/perl5.16')
-rw-r--r--lang/perl5.16/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/perl5.16/Makefile b/lang/perl5.16/Makefile
index 0f447b76e6d7..759396ef7f98 100644
--- a/lang/perl5.16/Makefile
+++ b/lang/perl5.16/Makefile
@@ -7,6 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -32,6 +33,7 @@ OPTIONS= DEBUGGING "Build with debugging support" off \
PERL_MALLOC "Use Perl malloc" off \
PERL_64BITINT "Use 64 bit integers (on i386)" on \
THREADS "Build threaded perl" off \
+ PTHREAD "Build with -pthread" on \
MULTIPLICITY "Use multiplicity" off \
SITECUSTOMIZE "Run-time customization of @INC" off \
USE_PERL "Rewrite links in /usr/bin" on
@@ -118,6 +120,7 @@ WITH_PERL_MALLOC= yes
#XXX .endif
CONFIGURE_ARGS+= -Dusethreads=y
PKGNAMESUFFIX= -threaded
+WITH_PTHREAD= yes
# it seems perl malloc has problems with threaded perl on FreeBSD
.undef WITH_PERL_MALLOC
.else
@@ -188,7 +191,7 @@ post-patch:
${BSDPAN_WRKSRC}/ExtUtils/*.pm
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
-.if defined(WITH_THREADS)
+.if defined(WITH_PTHREAD)
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g;' \
-e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g;' \
${WRKSRC}/hints/freebsd.sh