aboutsummaryrefslogtreecommitdiffstats
path: root/lang/phantomjs
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-24 19:06:57 +0800
committertijl <tijl@FreeBSD.org>2016-09-24 19:06:57 +0800
commit066998172e46dd08df392ecd35af710e3dd3da2a (patch)
treee47126c6c357762b62f9e5736c3d27d12948e676 /lang/phantomjs
parent49712f6fc0b0b344ad61319c9fe1eefaae4bc422 (diff)
downloadfreebsd-ports-gnome-066998172e46dd08df392ecd35af710e3dd3da2a.tar.gz
freebsd-ports-gnome-066998172e46dd08df392ecd35af710e3dd3da2a.tar.zst
freebsd-ports-gnome-066998172e46dd08df392ecd35af710e3dd3da2a.zip
- Update devel/icu to 57.1.
- Clean up the Makefile. - Follow some upstream recommendations (--with-data-packaging=archive, --disable-renaming, -DICU_NO_USER_DATA_OVERRIDE). - Patch makefiles to install static libraries with INSTALL_DATA so they aren't stripped. - Patch config/mh-bsd-gcc to sync with config/mh-linux-gcc. - Fix endianness detection in ICU. The code wanted to use BYTE_ORDER defined in machine/endian.h, but this isn't visible because ICU is compiled with _XOPEN_SOURCE. Patch the code to use _BYTE_ORDER instead. - Compile ICU with C++11 compiler to enable move constructors. - Patch ICU to fix a problem with atomics in the case of a C++11 compiler without C++11 header <atomic> (like Clang on FreeBSD 9). - Bump all ports that depend on it due to library version change. - Add USES=compiler:c++0x to some ports that pick up -std=c++0x from ICU pkgconfig files. - Add USES=compiler:c++11-lib to graphics/libcdr01 because it also needs a C++11 runtime library now. Add this to all ports that depend on it so their executables load the right libstdc++.so on FreeBSD 9. PR: 205120 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'lang/phantomjs')
-rw-r--r--lang/phantomjs/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index a31cf7b6e72c..e86707dd13f8 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -2,7 +2,7 @@
PORTNAME= phantomjs
PORTVERSION= 2.0.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang
MASTER_SITES= https://bitbucket.org/ariya/phantomjs/downloads/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source