aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pharo
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-05-12 04:31:46 +0800
committerPawel Pekala <pawel@FreeBSD.org>2012-05-12 04:31:46 +0800
commit8928bc850ed9fcb3ed3c7aed0f2d2a93b4f7e112 (patch)
tree6c4f8fb9839205499a247e144219e40379fd34c2 /lang/pharo
parent65bc55f3b60af86378f4ef173cbda46d1ca140da (diff)
downloadfreebsd-ports-gnome-8928bc850ed9fcb3ed3c7aed0f2d2a93b4f7e112.tar.gz
freebsd-ports-gnome-8928bc850ed9fcb3ed3c7aed0f2d2a93b4f7e112.tar.zst
freebsd-ports-gnome-8928bc850ed9fcb3ed3c7aed0f2d2a93b4f7e112.zip
Pharo is a clean, innovative, open-source Smalltalk-inspired environment.
- pure object-oriented language - runs on all major platforms - stable core with large test suite - a clean look and feel - good developer tools - low memory footprint It runs under squeak virtual machine. WWW: http://www.pharo-project.org/ PR: ports/167418 Submitted by: mutoh@openedu.org
Diffstat (limited to 'lang/pharo')
-rw-r--r--lang/pharo/Makefile45
-rw-r--r--lang/pharo/distinfo2
-rw-r--r--lang/pharo/pkg-descr11
3 files changed, 58 insertions, 0 deletions
diff --git a/lang/pharo/Makefile b/lang/pharo/Makefile
new file mode 100644
index 000000000000..15de65b95284
--- /dev/null
+++ b/lang/pharo/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: pharo
+# Date created: 26 April 2012
+# Whom: mutoh@openedu.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pharo
+DISTVERSION= 1.4
+CATEGORIES= lang
+MASTER_SITES= https://gforge.inria.fr/frs/download.php/30620/
+DISTNAME= Pharo-${DISTVERSION}-${SVNVERSION}
+EXTRACT_ONLY= Pharo-${DISTVERSION}-${SVNVERSION}.zip
+
+MAINTAINER= mutoh@openedu.org
+COMMENT= Pharo is Smalltalk-inspired environment
+
+LICENSE= AL2 MIT
+LICENSE_COMB= multi
+
+RUN_DEPENDS= squeak:${PORTSDIR}/lang/squeak
+
+SVNVERSION= 14438
+
+NO_BUILD= yes
+USE_ZIP= yes
+
+SHAREMODE= 644
+
+DIST_SUBDIR= squeak
+
+FILES_DIR= ${WRKDIR}/Pharo-${DISTVERSION}-${SVNVERSION}/
+FILES_TO_INSTALL=Pharo-${DISTVERSION}.image \
+ Pharo-${DISTVERSION}.changes \
+ PharoV10.sources
+PLIST_FILES= lib/squeak/Pharo-${DISTVERSION}.image \
+ lib/squeak/Pharo-${DISTVERSION}.changes \
+ lib/squeak/PharoV10.sources
+
+do-install:
+.for f in ${FILES_TO_INSTALL}
+ (cd ${FILES_DIR} && ${INSTALL_DATA} ${f} ${PREFIX}/lib/squeak/)
+.endfor
+
+.include <bsd.port.mk>
diff --git a/lang/pharo/distinfo b/lang/pharo/distinfo
new file mode 100644
index 000000000000..336094d99abe
--- /dev/null
+++ b/lang/pharo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (squeak/Pharo-1.4-14438.zip) = 7f1a3fa43f44f3f4d05955cd1b1191abcdb8f3ee9692eeb55d67ef0122324f1d
+SIZE (squeak/Pharo-1.4-14438.zip) = 13324537
diff --git a/lang/pharo/pkg-descr b/lang/pharo/pkg-descr
new file mode 100644
index 000000000000..3641e8033e69
--- /dev/null
+++ b/lang/pharo/pkg-descr
@@ -0,0 +1,11 @@
+Pharo is a clean, innovative, open-source Smalltalk-inspired environment.
+- pure object-oriented language
+- runs on all major platforms
+- stable core with large test suite
+- a clean look and feel
+- good developer tools
+- low memory footprint
+
+It runs under squeak virtual machine.
+
+WWW: http://www.pharo-project.org/