aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php4/files
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-03-27 00:44:25 +0800
committerale <ale@FreeBSD.org>2004-03-27 00:44:25 +0800
commit2dc0cd6f6c0ccdc5e766c04580d515d4f3d85ae7 (patch)
tree7e6e8badadc3314225aa6fabf016896a236b60a9 /lang/php4/files
parent3d646d2027c8b16fa4cfe710dab04f83226126df (diff)
downloadfreebsd-ports-gnome-2dc0cd6f6c0ccdc5e766c04580d515d4f3d85ae7.tar.gz
freebsd-ports-gnome-2dc0cd6f6c0ccdc5e766c04580d515d4f3d85ae7.tar.zst
freebsd-ports-gnome-2dc0cd6f6c0ccdc5e766c04580d515d4f3d85ae7.zip
Update to 4.3.5 release:
- add support for db 4.2
Diffstat (limited to 'lang/php4/files')
-rw-r--r--lang/php4/files/patch-configure80
-rw-r--r--lang/php4/files/patch-ext::gd::libgd::gdft.c14
-rw-r--r--lang/php4/files/patch-scripts::Makefile.frag11
3 files changed, 34 insertions, 71 deletions
diff --git a/lang/php4/files/patch-configure b/lang/php4/files/patch-configure
index 2e87a132a3a1..83b46f3a6d3e 100644
--- a/lang/php4/files/patch-configure
+++ b/lang/php4/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Mon Nov 3 00:27:51 2003
-+++ configure Sat Jan 24 12:58:20 2004
+--- configure.orig Thu Mar 25 15:03:34 2004
++++ configure Fri Mar 26 16:36:02 2004
@@ -617,6 +617,8 @@
ac_help="$ac_help
--enable-gd-jis-conv GD: Enable JIS-mapped Japanese font support."
@@ -8,8 +8,8 @@
+ac_help="$ac_help
--with-gettext[=DIR] Include GNU gettext support."
ac_help="$ac_help
- --with-gmp Include GNU MP support"
-@@ -23070,6 +23072,10 @@
+ --with-gmp[=DIR] Include GNU MP support"
+@@ -23147,6 +23149,10 @@
THIS_PREFIX=$i
THIS_INCLUDE=$i/db4/db.h
break
@@ -20,16 +20,16 @@
elif test -f "$i/include/db4/db.h"; then
THIS_PREFIX=$i
THIS_INCLUDE=$i/include/db4/db.h
-@@ -23089,7 +23095,7 @@
+@@ -23166,7 +23172,7 @@
fi
done
-- for LIB in db-4.1 db-4.0 db-4 db4 db; do
-+ for LIB in db-4.1 db-4.0 db-4 db41 db4 db; do
+- for LIB in db-4.2 db-4.1 db-4.0 db-4 db4 db; do
++ for LIB in db-4.2 db-4.1 db-4.0 db-4 db41 db4 db; do
if test -f $THIS_PREFIX/lib/lib$LIB.a -o -f $THIS_PREFIX/lib/lib$LIB.$SHLIB_SUFFIX_NAME; then
old_LDFLAGS=$LDFLAGS
-@@ -29623,6 +29629,31 @@
+@@ -29711,6 +29717,31 @@
@@ -61,7 +61,7 @@
-@@ -29775,7 +29806,7 @@
+@@ -29863,7 +29894,7 @@
libgd/gd_io_file.c libgd/gd_ss.c libgd/gd_io_ss.c libgd/gd_png.c libgd/gd_jpeg.c \
libgd/gdxpm.c libgd/gdfontt.c libgd/gdfonts.c libgd/gdfontmb.c libgd/gdfontl.c \
libgd/gdfontg.c libgd/gdtables.c libgd/gdft.c libgd/gdcache.c libgd/gdkanji.c \
@@ -70,7 +70,7 @@
libgd/xbm.c"
for ac_func in fabsf floorf
-@@ -29850,6 +29881,11 @@
+@@ -29938,6 +29969,11 @@
fi
@@ -82,7 +82,7 @@
if test "$PHP_JPEG_DIR" != "no"; then
for i in $PHP_JPEG_DIR /usr/local /usr; do
-@@ -31561,6 +31597,9 @@
+@@ -31649,6 +31685,9 @@
cat >> confdefs.h <<\EOF
#define HAVE_GD_BUNDLED 1
@@ -92,7 +92,7 @@
EOF
cat >> confdefs.h <<\EOF
-@@ -31615,6 +31654,14 @@
+@@ -31703,6 +31742,14 @@
GDLIB_CFLAGS="$GDLIB_CFLAGS -DJISX0208"
fi
@@ -107,7 +107,7 @@
else
if test "$PHP_GD" != "no"; then
-@@ -35964,6 +36011,137 @@
+@@ -36052,6 +36099,137 @@
esac
done
@@ -243,9 +243,9 @@
+ done
+
echo $ac_n "checking for gdCacheCreate in -lgd""... $ac_c" 1>&6
- echo "configure:35969: checking for gdCacheCreate in -lgd" >&5
+ echo "configure:36057: checking for gdCacheCreate in -lgd" >&5
ac_lib_var=`echo gd'_'gdCacheCreate | sed 'y%./+-%__p_%'`
-@@ -61825,6 +62003,102 @@
+@@ -62586,6 +62764,102 @@
if test "$ext_shared" = "yes"; then
@@ -348,7 +348,7 @@
ORACLE_SHARED_LIBADD="-lnlsrtl3 $ORACLE_SHARED_LIBADD"
if test -n "$ORACLE_DIR/lib"; then
-@@ -79004,29 +79278,6 @@
+@@ -79741,29 +80015,6 @@
else
@@ -378,7 +378,7 @@
case ct in
c|c_r|pthread*) ;;
*)
-@@ -79050,52 +79301,7 @@
+@@ -79787,52 +80038,7 @@
@@ -432,10 +432,21 @@
save_old_LDFLAGS=$LDFLAGS
-@@ -79241,38 +79447,6 @@
-
-
-
+@@ -79967,38 +80173,6 @@
+ c|c_r|pthread*) ;;
+ *)
+ LIBS="-ltcl $LIBS"
+- ;;
+- esac
+-
+-
+- fi
+- ;;
+- esac
+-
+-
+-
+-
-else
- echo "$ac_t""no" 1>&6
-
@@ -457,29 +468,6 @@
- c|c_r|pthread*) ;;
- *)
- LIBS="-lsybtcl $LIBS"
-- ;;
-- esac
--
--
-- fi
-- ;;
-- esac
--
--
--
--
- fi
-
-
-@@ -93087,10 +93261,7 @@
- CXXFLAGS="$CXXFLAGS $standard_libtool_flag"
-
- all_targets='$(OVERALL_TARGET) $(PHP_MODULES) $(PHP_CLI_TARGET)'
--install_targets="install-sapi install-modules $install_pear install-build install-headers install-programs"
--if test "$PHP_SAPI" != "cgi"; then
-- install_targets="$PHP_INSTALL_CLI_TARGET $install_targets"
--fi
-+install_targets="install-sapi $PHP_INSTALL_CLI_TARGET install-modules $install_pear install-build install-headers install-programs"
-
+ ;;
+ esac
- PHP_VAR_SUBST="$PHP_VAR_SUBST all_targets"
diff --git a/lang/php4/files/patch-ext::gd::libgd::gdft.c b/lang/php4/files/patch-ext::gd::libgd::gdft.c
deleted file mode 100644
index 31e16dc71e8b..000000000000
--- a/lang/php4/files/patch-ext::gd::libgd::gdft.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ext/gd/libgd/gdft.c.orig Thu Mar 18 16:41:43 2004
-+++ ext/gd/libgd/gdft.c Thu Mar 18 16:49:39 2004
-@@ -60,8 +60,9 @@
- #else
-
- #include "gdcache.h"
--#include "freetype/freetype.h"
--#include "freetype/ftglyph.h"
-+#include <ft2build.h>
-+#include FT_FREETYPE_H
-+#include FT_GLYPH_H
-
- /* number of fonts cached before least recently used is replaced */
- #define FONTCACHESIZE 6
diff --git a/lang/php4/files/patch-scripts::Makefile.frag b/lang/php4/files/patch-scripts::Makefile.frag
deleted file mode 100644
index 0d522f07c4a6..000000000000
--- a/lang/php4/files/patch-scripts::Makefile.frag
+++ /dev/null
@@ -1,11 +0,0 @@
---- scripts/Makefile.frag.orig Fri Sep 19 07:35:21 2003
-+++ scripts/Makefile.frag Sat Nov 22 15:32:41 2003
-@@ -32,6 +32,8 @@
- ext/xml/expat \
- main \
- ext/mbstring \
-+ ext/mbstring/libmbfl \
-+ ext/mbstring/libmbfl/mbfl \
- ext/pgsql \
- regex
-