aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php4
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-06-06 04:02:03 +0800
committerpav <pav@FreeBSD.org>2005-06-06 04:02:03 +0800
commit8c7895d34bb474e40b41720d3141362fc4f0c1e9 (patch)
tree7b12362715454a31e0753811d959c23b91a43ccb /lang/php4
parent82d365fcb9f0c87bdd8486d938178fac1def4a21 (diff)
downloadfreebsd-ports-gnome-8c7895d34bb474e40b41720d3141362fc4f0c1e9.tar.gz
freebsd-ports-gnome-8c7895d34bb474e40b41720d3141362fc4f0c1e9.tar.zst
freebsd-ports-gnome-8c7895d34bb474e40b41720d3141362fc4f0c1e9.zip
- allow php4-dba to use Berkeley DB 4.3
PR: ports/76150 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net> Approved by: maintainer timeout (5 months)
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile.ext4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index ca0464e673ef..002a91252647 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -389,6 +389,9 @@ CONFIGURE_ARGS+=--without-cdb
. endif
. if defined(WITH_DB4)
WITH_DB4_VER?= 41
+. if ${WITH_DB4_VER} == 43
+LIB_DEPENDS+= db-4.3.0:${PORTSDIR}/databases/db43
+. else
. if ${WITH_DB4_VER} == 42
LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
. else
@@ -398,6 +401,7 @@ LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
. endif
. endif
+. endif
CONFIGURE_ARGS+=--with-db4=${LOCALBASE}
. endif
. if defined(WITH_GDBM)