aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php4
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-06-14 22:27:20 +0800
committerAlex Dupre <ale@FreeBSD.org>2005-06-14 22:27:20 +0800
commitc6543f91246fdf3097aad7445ae9c5ea950ffb24 (patch)
tree31555b6d41a6951c036044dfb2959a5fe74884a7 /lang/php4
parent78bb8a76a4c6b2e5f0cd428c0f7b969e90a8f19b (diff)
downloadfreebsd-ports-gnome-c6543f91246fdf3097aad7445ae9c5ea950ffb24.tar.gz
freebsd-ports-gnome-c6543f91246fdf3097aad7445ae9c5ea950ffb24.tar.zst
freebsd-ports-gnome-c6543f91246fdf3097aad7445ae9c5ea950ffb24.zip
Fix oracle extension.
PR: ports/81382 Submitted by: Simun Mikecin <sime@logos.hr>
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile.ext11
1 files changed, 9 insertions, 2 deletions
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index 002a91252647..75c153c20bee 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -32,7 +32,6 @@ CONFIGURE_ARGS+=--enable-calendar
.if ${PHP_MODNAME} == "crack"
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcrack.a:${PORTSDIR}/security/cracklib
-RUN_DEPENDS+= ${LOCALBASE}/lib/libcrack.a:${PORTSDIR}/security/cracklib
CONFIGURE_ARGS+=--with-crack=${LOCALBASE}
.endif
@@ -242,7 +241,6 @@ USE_OPENSSL= yes
.if ${PHP_MODNAME} == "oracle"
BUILD_DEPENDS+= ${LOCALBASE}/oracle7/lib/libcore3.a:${PORTSDIR}/databases/oracle7-client
-RUN_DEPENDS+= ${LOCALBASE}/oracle7/lib/libcore3.a:${PORTSDIR}/databases/oracle7-client
CONFIGURE_ARGS+=--with-oracle=${LOCALBASE}/oracle7
.endif
@@ -450,6 +448,15 @@ post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif
+.if ${PHP_MODNAME} == "oracle"
+post-patch:
+ @cd ${WRKSRC}; \
+ for lib in c3v6 client common core3 epc generic ncr nlsrtl3 sqlnet wrap; do \
+ /usr/bin/ar x ${LOCALBASE}/oracle7/lib/lib$${lib}.a; \
+ done; \
+ /usr/bin/ar rcs liboracle.a *.o
+.endif
+
.if ${PHP_MODNAME} == "snmp"
. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4