aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5/Makefile.ext
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2008-12-07 19:54:36 +0800
committerale <ale@FreeBSD.org>2008-12-07 19:54:36 +0800
commit32dcfd80bd4cce5e3893332449cbd46872942c4d (patch)
tree6d66c38223ff470133dd1e25e37def561d06ba26 /lang/php5/Makefile.ext
parent0223905cb34c313d1482e2e02dc6fd1623e8a010 (diff)
downloadfreebsd-ports-gnome-32dcfd80bd4cce5e3893332449cbd46872942c4d.tar.gz
freebsd-ports-gnome-32dcfd80bd4cce5e3893332449cbd46872942c4d.tar.zst
freebsd-ports-gnome-32dcfd80bd4cce5e3893332449cbd46872942c4d.zip
Update to 5.2.7 release.
Diffstat (limited to 'lang/php5/Makefile.ext')
-rw-r--r--lang/php5/Makefile.ext43
1 files changed, 5 insertions, 38 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index c1554bb9dc84..0d70b753b2e8 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -233,12 +233,6 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+=--enable-pcntl
.endif
-.if ${PHP_MODNAME} == "pcre"
-CONFIGURE_ARGS+=--with-pcre-regex=yes
-
-PHP_HEADER_DIRS=pcrelib
-.endif
-
.if ${PHP_MODNAME} == "pdo"
CONFIGURE_ARGS+=--enable-pdo
.endif
@@ -386,7 +380,7 @@ CONFIGURE_ARGS+=--enable-spl \
USE_GNOME= libxml2
-USE_PHP= pcre simplexml
+USE_PHP= simplexml
USE_PHP_BUILD= yes
.endif
@@ -502,33 +496,11 @@ CONFIGURE_ARGS+=--with-zlib=/usr
CONFIGURE_ARGS+=--without-cdb
. endif
. if defined(WITH_DB4)
-WITH_DB4_VER?= 46
-. if ${WITH_DB4_VER} == 45
-LIB_DEPENDS+= db-4.5.0:${PORTSDIR}/databases/db45
-. else
-. if ${WITH_DB4_VER} == 44
-LIB_DEPENDS+= db-4.4.0:${PORTSDIR}/databases/db44
-. else
-. if ${WITH_DB4_VER} == 43
-LIB_DEPENDS+= db-4.3.0:${PORTSDIR}/databases/db43
-. else
-. if ${WITH_DB4_VER} == 42
-LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
-. else
-. if ${WITH_DB4_VER} == 41
-LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
-. else
-. if ${WITH_DB4_VER} == 4
-LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
-. else
-LIB_DEPENDS+= db-4.6.0:${PORTSDIR}/databases/db46
-. endif
-. endif
-. endif
-. endif
-. endif
-. endif
CONFIGURE_ARGS+=--with-db4=${LOCALBASE}
+
+USE_BDB= yes
+WITH_BDB_HIGHEST= yes
+INVALID_BDB_VER= 2 3
. endif
. if defined(WITH_GDBM)
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
@@ -577,11 +549,6 @@ post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif
-.if ${PHP_MODNAME} == "pcre"
-post-extract:
- @${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
-.endif
-
.if ${PHP_MODNAME} == "oci8" || ${PHP_MODNAME} == "pdo_oci"
pre-configure:
@cd ${WRKSRC}; \