aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5/files
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-11-16 16:33:09 +0800
committerale <ale@FreeBSD.org>2005-11-16 16:33:09 +0800
commit2b1dc0524614c6e4aa6ad94e8c9dad452e06e853 (patch)
treec96e67349a2a060a43b33db3fe98fc2df45bfa88 /lang/php5/files
parent3e385f9d95a47f72c86a3888ab7156d1af71c36b (diff)
downloadfreebsd-ports-gnome-2b1dc0524614c6e4aa6ad94e8c9dad452e06e853.tar.gz
freebsd-ports-gnome-2b1dc0524614c6e4aa6ad94e8c9dad452e06e853.tar.zst
freebsd-ports-gnome-2b1dc0524614c6e4aa6ad94e8c9dad452e06e853.zip
- Fix pear pkg-plist
- Increase pear memory limit (requested by amd64)
Diffstat (limited to 'lang/php5/files')
-rw-r--r--lang/php5/files/patch-Zend::zend.h11
-rw-r--r--lang/php5/files/patch-acinclude.m48
-rw-r--r--lang/php5/files/patch-main::php_config.h.in10
-rw-r--r--lang/php5/files/patch-pear::scripts::pearcmd.php9
4 files changed, 19 insertions, 19 deletions
diff --git a/lang/php5/files/patch-Zend::zend.h b/lang/php5/files/patch-Zend::zend.h
index 50625c403417..701f6a556f56 100644
--- a/lang/php5/files/patch-Zend::zend.h
+++ b/lang/php5/files/patch-Zend::zend.h
@@ -1,12 +1,11 @@
---- Zend/zend.h.orig Mon Dec 6 15:42:56 2004
-+++ Zend/zend.h Mon Dec 6 15:46:40 2004
-@@ -176,7 +176,7 @@
+--- Zend/zend.h.orig Thu Aug 25 19:41:08 2005
++++ Zend/zend.h Wed Nov 16 09:30:03 2005
+@@ -178,7 +178,7 @@
#endif
-
-
+
+
-#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__)
+#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__) && !(defined(ZTS) && defined(__FreeBSD__))
# define do_alloca(p) alloca(p)
# define free_alloca(p)
#else
-
diff --git a/lang/php5/files/patch-acinclude.m4 b/lang/php5/files/patch-acinclude.m4
index 32a0ca4c79c9..925902e0e2e8 100644
--- a/lang/php5/files/patch-acinclude.m4
+++ b/lang/php5/files/patch-acinclude.m4
@@ -1,7 +1,7 @@
---- acinclude.m4.orig Tue Jan 25 14:02:45 2005
-+++ acinclude.m4 Mon Apr 4 11:09:25 2005
-@@ -1681,9 +1681,9 @@
- unset OPENSSL_LIBDIR
+--- acinclude.m4.orig Tue Jul 26 00:31:07 2005
++++ acinclude.m4 Wed Nov 16 09:30:03 2005
+@@ -1707,9 +1707,9 @@
+ test -z "$PHP_IMAP_SSL" && PHP_IMAP_SSL=no
dnl Fallbacks for different configure options
- if test "$PHP_OPENSSL" != "no"; then
diff --git a/lang/php5/files/patch-main::php_config.h.in b/lang/php5/files/patch-main::php_config.h.in
index 3eed7c4acf66..9c92108b381e 100644
--- a/lang/php5/files/patch-main::php_config.h.in
+++ b/lang/php5/files/patch-main::php_config.h.in
@@ -1,8 +1,8 @@
---- main/php_config.h.in.orig Mon Jul 12 16:30:37 2004
-+++ main/php_config.h.in Mon Jul 12 16:31:38 2004
-@@ -2362,6 +2362,9 @@
- /* */
- #undef SOLARIS_YP
+--- main/php_config.h.in.orig Mon Sep 5 13:16:27 2005
++++ main/php_config.h.in Wed Nov 16 09:30:03 2005
+@@ -2454,6 +2454,9 @@
+ /* Define if uint32_t type is present. */
+ #undef HAVE_UINT32_T
+/* Include external shared modules configurations */
+#include "ext/php_config.h"
diff --git a/lang/php5/files/patch-pear::scripts::pearcmd.php b/lang/php5/files/patch-pear::scripts::pearcmd.php
index d24ae913d4fe..e0898d9ed08a 100644
--- a/lang/php5/files/patch-pear::scripts::pearcmd.php
+++ b/lang/php5/files/patch-pear::scripts::pearcmd.php
@@ -1,11 +1,11 @@
---- pear/scripts/pearcmd.php.orig Sun Jun 6 17:52:41 2004
-+++ pear/scripts/pearcmd.php Mon Jul 12 16:22:50 2004
+--- pear/scripts/pearcmd.php.orig Mon Mar 28 18:46:06 2005
++++ pear/scripts/pearcmd.php Wed Nov 16 09:30:03 2005
@@ -1,3 +1,4 @@
+#!%%PREFIX%%/bin/php -nq
<?php
//
// +----------------------------------------------------------------------+
-@@ -24,9 +25,9 @@
+@@ -24,9 +25,10 @@
/**
* @nodep Gtk
*/
@@ -15,6 +15,7 @@
+dl('pcre.so');
+dl('xml.so');
+ini_set('include_path', '%%PREFIX%%/share/pear:%%PREFIX%%/share/pear/bootstrap');
++ini_set('memory_limit', '16M');
ini_set('allow_url_fopen', true);
if (!ini_get('safe_mode')) {
- set_time_limit(0);
+ @set_time_limit(0);