aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php53
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-05-07 22:47:28 +0800
committerAlex Dupre <ale@FreeBSD.org>2006-05-07 22:47:28 +0800
commit3b7908241d6e1cf284e9ccdec13b0b8a0a6a4c1c (patch)
tree33d8ad9b0d9b8ebf8bac4fa06654e7e66dec27c7 /lang/php53
parent0d01beefd877fae55ff560dc302fe79fc47f8e44 (diff)
downloadfreebsd-ports-gnome-3b7908241d6e1cf284e9ccdec13b0b8a0a6a4c1c.tar.gz
freebsd-ports-gnome-3b7908241d6e1cf284e9ccdec13b0b8a0a6a4c1c.tar.zst
freebsd-ports-gnome-3b7908241d6e1cf284e9ccdec13b0b8a0a6a4c1c.zip
Add WITH_ZEND_VM knob to customize vm behaviour:
- CALL is the default one - SWITCH should be slightly faster - GOTO should boost performance (and increase compilation time) Suggested by: Michael Josic <systemoperator@gmail.com>
Diffstat (limited to 'lang/php53')
-rw-r--r--lang/php53/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 47a564c6e1c8..36a0f5256094 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -115,6 +115,14 @@ CONFIGURE_ARGS+=--with-regex=system
CONFIGURE_ARGS+=--with-regex=apache
.endif
+.if !defined(WITH_ZEND_VM) || ${WITH_ZEND_VM} == "CALL"
+CONFIGURE_ARGS+=--with-zend-vm=CALL
+.elif defined(WITH_ZEND_VM) && ${WITH_ZEND_VM} == "SWITCH"
+CONFIGURE_ARGS+=--with-zend-vm=SWITCH
+.elif defined(WITH_ZEND_VM) && ${WITH_ZEND_VM} == "GOTO"
+CONFIGURE_ARGS+=--with-zend-vm=GOTO
+.endif
+
CONFIGURE_ENV+= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
ac_cv_pthreads_cflags=${PTHREAD_CFLAGS} \
pthreads_working="yes"