aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-07-03 13:51:18 +0800
committernork <nork@FreeBSD.org>2003-07-03 13:51:18 +0800
commit005d1c5e60220abcef28067eb7b5b8963407b322 (patch)
tree5bfac93409f30d820d3aad515b3b7661f4a9142b /lang/php5
parent18a55471452d65c8b4cfb34160a8a3924538b656 (diff)
downloadfreebsd-ports-gnome-005d1c5e60220abcef28067eb7b5b8963407b322.tar.gz
freebsd-ports-gnome-005d1c5e60220abcef28067eb7b5b8963407b322.tar.zst
freebsd-ports-gnome-005d1c5e60220abcef28067eb7b5b8963407b322.zip
Add WANT_PHP_WEB knob, for ports that require a web
server to work, but for which is indifferent the PHP sapi (CGI or Apache Module). PR: ports/53800 Submitted by: Alex Dupre <sysadmin@alexdupre.com> (maintainer)
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/bsd.php.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/lang/php5/bsd.php.mk b/lang/php5/bsd.php.mk
index f315c3c4d1fb..59f7191d50dd 100644
--- a/lang/php5/bsd.php.mk
+++ b/lang/php5/bsd.php.mk
@@ -6,6 +6,7 @@
# WANT_PHP_CLI=yes - Want the CLI version of PHP.
# WANT_PHP_CGI=yes - Want the CGI version of PHP.
# WANT_PHP_MOD=yes - Want the Apache Module for PHP.
+# WANT_PHP_WEB=yes - Want the Apache Module or the CGI version of PHP.
#
# You may combine multiple WANT_PHP_* knobs.
# Don't specify any WANT_PHP_* knob if your port will work with every PHP SAPI.
@@ -48,6 +49,17 @@ PHP_PORT?= ${PORTSDIR}/lang/php4-cli
.endif
.endif
+.if defined(WANT_PHP_WEB)
+.if defined(HAVE_PHP) && !defined(HAVE_PHP_CGI) && !defined(HAVE_PHP_MOD)
+.BEGIN:
+ @${ECHO_CMD} "This port requires the Apache Module or the CGI version of PHP, but you have"
+ @${ECHO_CMD} "already installed a conflicting PHP port without them."
+ @${FALSE}
+.else
+PHP_PORT?= ${PORTSDIR}/www/mod_php4
+.endif
+.endif
+
.if defined(WANT_PHP_CGI)
.if defined(HAVE_PHP) && !defined(HAVE_PHP_CGI)
.BEGIN: