aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-01-14 23:09:26 +0800
committerale <ale@FreeBSD.org>2004-01-14 23:09:26 +0800
commit2e333ab262cd13a924d332fdc18c029735fdfe19 (patch)
tree19969cde025659ee01c0fc475f9be0fc69b92c90 /lang/php5
parentedc8eb4b555e2d838f15a416c4bf3fd748fb8823 (diff)
downloadfreebsd-ports-gnome-2e333ab262cd13a924d332fdc18c029735fdfe19.tar.gz
freebsd-ports-gnome-2e333ab262cd13a924d332fdc18c029735fdfe19.tar.zst
freebsd-ports-gnome-2e333ab262cd13a924d332fdc18c029735fdfe19.zip
- Fix apache2 dependency (this was broken by the introduction
of the APACHE_PORT variable in bsd.port.mk). - Fix php5 pkg-list when built without sqlite. Approved by: nork (mentor/implicitly)
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 72da22c10905..16342a80468f 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -526,7 +526,7 @@ APACHE_MPM!= ${APXS} -q MPM_NAME
.endif
.if defined(WITH_APACHE2)
APACHE_MPM?= ${WITH_MPM}
-APACHE_PORT?= www/apache2
+APACHE_PORT= www/apache2
CONFIGURE_ARGS+=--with-apxs2=${APXS}
SAPI_FILE= libexec/apache2/libphp5.so
.if ${APACHE_MPM} == "worker"
@@ -673,6 +673,7 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/php.ini-dist ${PREFIX}/etc
@${INSTALL_DATA} ${WRKSRC}/php.ini-recommended ${PREFIX}/etc
@${INSTALL_DATA} ${WRKDIR}/php.conf ${PREFIX}/etc
+ @${TOUCH} ${PREFIX}/include/php/ext/sqlite/libsqlite/src/sqlite.h
.if !defined(WITHOUT_APACHE)
@${ECHO_CMD} "*****************************************************************************"
@${ECHO_CMD} ""