aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-06-25 15:44:18 +0800
committerAlex Dupre <ale@FreeBSD.org>2010-06-25 15:44:18 +0800
commit68d81f0fe60dd0f32620c33571cffff87e1228cb (patch)
tree5f3b0caf8e5556fa14f40153be185dc948bfee8b /lang/php5
parent771b26eadb12af350175949c3cf7dc40954aac23 (diff)
downloadfreebsd-ports-gnome-68d81f0fe60dd0f32620c33571cffff87e1228cb.tar.gz
freebsd-ports-gnome-68d81f0fe60dd0f32620c33571cffff87e1228cb.tar.zst
freebsd-ports-gnome-68d81f0fe60dd0f32620c33571cffff87e1228cb.zip
Add an OPTION to force linking with libthr (default off). This is a hack needed
when using !ZTS PHP on FreeBSD 7.x/8.0 together with threaded extensions. Feature safe: yes
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 0c85693bfac0..dc506b278157 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -43,7 +43,8 @@ OPTIONS= CLI "Build CLI version" on \
SUHOSIN "Enable Suhosin protection system" on \
MULTIBYTE "Enable zend multibyte support" off \
IPV6 "Enable ipv6 support" on \
- MAILHEAD "Enable mail header patch" off
+ MAILHEAD "Enable mail header patch" off \
+ LINKTHR "Link thread lib (for threaded extensions)" off
CONFLICTS= php4-4* php5-pcre-* php5-spl-*
@@ -119,7 +120,9 @@ CONFIGURE_ENV+= ac_cv_pthreads_lib="" \
pthreads_working="yes" \
lt_cv_path_SED="sed"
-MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+.if defined(WITH_LINKTHR)
+CONFIGURE_ENV+= LIBS="${LIBS} ${PTHREAD_LIBS}"
+.endif
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+=--enable-debug