aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2010-09-07 22:30:03 +0800
committerale <ale@FreeBSD.org>2010-09-07 22:30:03 +0800
commit71f8d942a5d33516a57d4a61358869e142e14a26 (patch)
tree950027e372a39e5b508b0d505fba8c48f29f678d /lang/php5
parent2fb45d844b236672e954daac08beb6125c5e1980 (diff)
downloadfreebsd-ports-gnome-71f8d942a5d33516a57d4a61358869e142e14a26.tar.gz
freebsd-ports-gnome-71f8d942a5d33516a57d4a61358869e142e14a26.tar.zst
freebsd-ports-gnome-71f8d942a5d33516a57d4a61358869e142e14a26.zip
Replace pecl-fileinfo with php5-fileinfo for php 5.3.x.
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile.ext7
1 files changed, 7 insertions, 0 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index f969b6883ae1..a6c8f54be6bd 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -61,6 +61,13 @@ USE_GNOME= libxml2
CONFIGURE_ARGS+=--enable-exif
.endif
+.if ${PHP_MODNAME} == "fileinfo"
+CONFIGURE_ARGS+=--enable-fileinfo \
+ --with-pcre-dir=${LOCALBASE}
+
+PHP_HEADER_DIRS= libmagic
+.endif
+
.if ${PHP_MODNAME} == "filter"
CONFIGURE_ARGS+=--enable-filter \
--with-pcre-dir=${LOCALBASE}