aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php73
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2019-01-14 19:05:43 +0800
committertz <tz@FreeBSD.org>2019-01-14 19:05:43 +0800
commit24bac91747dc014d952872390620fea9ae436f82 (patch)
treed2fea8181652fcd85b9764e4b2ded66c04b49b64 /lang/php73
parent9741f4e417eabbf02fa250b2a9c8be7c11886559 (diff)
downloadfreebsd-ports-gnome-24bac91747dc014d952872390620fea9ae436f82.tar.gz
freebsd-ports-gnome-24bac91747dc014d952872390620fea9ae436f82.tar.zst
freebsd-ports-gnome-24bac91747dc014d952872390620fea9ae436f82.zip
lang/php73: Upgrade from 7.3.0 to 7.3.1
Changelog: Core: Fixed bug #76654 (Build failure on Mac OS X on 32-bit Intel). Fixed bug #71041 (zend_signal_startup() needs ZEND_API). Fixed bug #76046 (PHP generates "FE_FREE" opcode on the wrong line). Fixed bug #77291 (magic methods inherited from a trait may be ignored). CURL: Fixed bug #77264 (curl_getinfo returning microseconds, not seconds). COM: Fixed bug #77177 (Serializing or unserializing COM objects crashes). Exif: Fixed bug #77184 (Unsigned rational numbers are written out as signed rationals). GD: Fixed bug #77195 (Incorrect error handling of imagecreatefromjpeg()). Fixed bug #77198 (auto cropping has insufficient precision). Fixed bug #77200 (imagecropauto(…, GD_CROP_SIDES) crops left but not right). Fixed bug #77269 (efree() on uninitialized Heap data in imagescale leads to use-after-free). Fixed bug #77270 (imagecolormatch Out Of Bounds Write on Heap). MBString: Fixed bug #77367 (Negative size parameter in mb_split). Fixed bug #77370 (Buffer overflow on mb regex functions - fetch_token). Fixed bug #77371 (heap buffer overflow in mb regex functions - compile_string_node). Fixed bug #77381 (heap buffer overflow in multibyte match_at). Fixed bug #77382 (heap buffer overflow due to incorrect length in expand_case_fold_string). Fixed bug #77385 (buffer overflow in fetch_token). Fixed bug #77394 (Buffer overflow in multibyte case folding - unicode). Fixed bug #77418 (Heap overflow in utf32be_mbc_to_code). OCI8: Fixed bug #76804 (oci_pconnect with OCI_CRED_EXT not working). Added oci_set_call_timeout() for call timeouts. Added oci_set_db_operation() for the DBOP end-to-end-tracing attribute. Opcache: Fixed bug #77215 (CFG assertion failure on multiple finalizing switch frees in one block). Fixed bug #77275 (OPcache optimization problem for ArrayAccess->offsetGet). PCRE: Fixed bug #77193 (Infinite loop in preg_replace_callback). PDO: Handle invalid index passed to PDOStatement::fetchColumn() as error. Phar: Fixed bug #77247 (heap buffer overflow in phar_detect_phar_fname_ext). Soap: Fixed bug #77088 (Segfault when using SoapClient with null options). Sockets: Fixed bug #77136 (Unsupported IPV6_RECVPKTINFO constants on macOS). Sodium: Fixed bug #77297 (SodiumException segfaults on PHP 7.3). SPL: Fixed bug #77359 (spl_autoload causes segfault). Fixed bug #77360 (class_uses causes segfault). SQLite3: Fixed bug #77051 (Issue with re-binding on SQLite3). Xmlrpc: Fixed bug #77242 (heap out of bounds read in xmlrpc_decode()). Fixed bug #77380 (Global out of bounds read in xmlrpc base64 code). Changelog taken from: http://www.php.net/ChangeLog-7.php#7.3.1 Also removing the patch committed in r489721. The patch disables the use of ifuncs and is part of the new relase 7.3.1. MFH: 2019Q1
Diffstat (limited to 'lang/php73')
-rw-r--r--lang/php73/Makefile4
-rw-r--r--lang/php73/distinfo6
-rw-r--r--lang/php73/files/patch-configure.ac14
3 files changed, 5 insertions, 19 deletions
diff --git a/lang/php73/Makefile b/lang/php73/Makefile
index ebc45553d876..ef8fa334917a 100644
--- a/lang/php73/Makefile
+++ b/lang/php73/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= php73
-DISTVERSION= 7.3.0
-PORTREVISION?= 1
+DISTVERSION= 7.3.1
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${DISTVERSION}
diff --git a/lang/php73/distinfo b/lang/php73/distinfo
index e3fad3f35afd..0e97a8daa1fe 100644
--- a/lang/php73/distinfo
+++ b/lang/php73/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1544005190
-SHA256 (php-7.3.0.tar.xz) = 7d195cad55af8b288c3919c67023a14ff870a73e3acc2165a6d17a4850a560b5
-SIZE (php-7.3.0.tar.xz) = 11928820
+TIMESTAMP = 1547458364
+SHA256 (php-7.3.1.tar.xz) = cfe93e40be0350cd53c4a579f52fe5d8faf9c6db047f650a4566a2276bf33362
+SIZE (php-7.3.1.tar.xz) = 11944376
diff --git a/lang/php73/files/patch-configure.ac b/lang/php73/files/patch-configure.ac
deleted file mode 100644
index 4305bd53e717..000000000000
--- a/lang/php73/files/patch-configure.ac
+++ /dev/null
@@ -1,14 +0,0 @@
---- configure.ac.orig 2019-01-08 12:14:44 UTC
-+++ configure.ac
-@@ -579,7 +579,10 @@ PHP_SOCKADDR_CHECKS
-
- dnl Checks for GCC function attributes on all systems except ones without glibc
- dnl Fix for these systems is already included in GCC 7, but not on GCC 6
--AS_CASE([$host_alias], [*-*-*android*|*-*-*uclibc*|*-*-*musl*], [true], [
-+dnl
-+dnl At least some versions of FreeBSD seem to have buggy ifunc support, see
-+dnl bug #77284. Conservatively don't use ifuncs on FreeBSD.
-+AS_CASE([$host_alias], [*-*-*android*|*-*-*uclibc*|*-*-*musl*|*freebsd*], [true], [
- AX_GCC_FUNC_ATTRIBUTE([ifunc])
- AX_GCC_FUNC_ATTRIBUTE([target])
- ])