aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pure
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2018-05-20 16:34:11 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2018-05-20 16:34:11 +0800
commit3cb8fec077186fd487ad655555d469589df29713 (patch)
tree6bd7581addfbe5518077ed2a482ea4b8fc66c044 /lang/pure
parent8638aeb6f81ea13663b509848e04b4e887ad7555 (diff)
downloadfreebsd-ports-gnome-3cb8fec077186fd487ad655555d469589df29713.tar.gz
freebsd-ports-gnome-3cb8fec077186fd487ad655555d469589df29713.tar.zst
freebsd-ports-gnome-3cb8fec077186fd487ad655555d469589df29713.zip
- Switch to USES=libedit as suggested by stage-qa
- Switch to new test framework - Switch to options helpers Approved by: portmgr blanket
Diffstat (limited to 'lang/pure')
-rw-r--r--lang/pure/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/lang/pure/Makefile b/lang/pure/Makefile
index 24e98bdea3fa..1a3f526862f7 100644
--- a/lang/pure/Makefile
+++ b/lang/pure/Makefile
@@ -21,12 +21,13 @@ LIB_DEPENDS= libgmp.so:math/gmp \
SUB_FILES= pkg-message
-USES= gmake iconv pathfix pkgconfig
+USES= gmake iconv libedit pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libgmp-prefix=${LOCALBASE} --enable-release \
--with-pcre \
--with-tool-prefix=${LOCALBASE}/llvm${LLVM_VERSION}/bin
EXTRACT_AFTER_ARGS=--no-same-owner --no-same-permissions --exclude texmacs
+TEST_TARGET= check # XXX: some tests fail
USE_LDCONFIG= yes
PORTDOCS= *
@@ -65,9 +66,6 @@ post-patch:
-e 's,"+interp.libdir+"docs,${DOCSDIR},g' \
${WRKSRC}/lexer.cc
-test check regression-test: build
- ${GMAKE} -C ${WRKSRC} check
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
@@ -93,23 +91,22 @@ CONFIGURE_ARGS+=ac_cv_lib_iconv_libiconv=no ac_cv_lib_iconv_iconv=no
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pure \
${STAGEDIR}${PREFIX}/lib/libpure.so.*.*
-.if ${PORT_OPTIONS:METC}
+
+post-install-ETC-on:
@${MKDIR} ${STAGEDIR}${DATADIR}/etc/
@(cd ${WRKSRC} && ${RM} etc/*.in && ${COPYTREE_SHARE} etc/ ${STAGEDIR}${DATADIR})
-.endif
-.if ${PORT_OPTIONS:MDOCS}
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${TAR} -C ${STAGEDIR}${DOCSDIR} --strip-components 1 \
--exclude Makefile --exclude '*.tm' \
${EXTRACT_AFTER_ARGS} \
-xpf ${_DISTDIR}${_DISTFILES:M*-docs*}
${FIND} ${STAGEDIR}${DOCSDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
-.endif
.include <bsd.port.post.mk>